EP3 stalls after getting gas. evap code

K-Series Programmable ECU installation questions / support issues
ep3steeze
Posts: 12
Joined: Thu May 01, 2014 7:55 am

Re: EP3 stalls after getting gas. evap code

Post by ep3steeze » Sun May 04, 2014 7:35 am

I didnt know what kind of datalog you guys wanted so i just did a basic mid throttle and full throttle.. i can get a datalog the next time i get gas.

ep3steeze
Posts: 12
Joined: Thu May 01, 2014 7:55 am

Re: EP3 stalls after getting gas. evap code

Post by ep3steeze » Tue May 06, 2014 5:52 pm

Here is a datalog of my car stalling after getting gas. Also i got the Serial Number. 14052 (thats what shows up in my kmanager)

Thanks
Attachments
Fueling up 2.kdl
(290.09 KiB) Downloaded 51 times

User avatar
Hondata
Site Admin
Posts: 8686
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: EP3 stalls after getting gas. evap code

Post by Hondata » Wed May 07, 2014 6:38 am

One problem I see is that the TPS is not adjusted, so on overrun the fuel injectors are not shutting down, and that gives it a large negative fuel trim. This makes it go very lean when you get back on the throttle.

Can you do a slightly longer datalog with it stalling, where it gets into closed loop first? I realize that it may be difficult to do, but it would help.
Hondata

ep3steeze
Posts: 12
Joined: Thu May 01, 2014 7:55 am

Re: EP3 stalls after getting gas. evap code

Post by ep3steeze » Wed May 07, 2014 7:04 am

So my TPS needs to be adjusted correctly? What exactly do you mean "where it gets into closed loop first?" Would that be datalogging it after the stale out for a minute or two so the oxygen sensor can read and adjust the afr's?

User avatar
Hondata
Site Admin
Posts: 8686
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: EP3 stalls after getting gas. evap code

Post by Hondata » Wed May 07, 2014 9:14 am

Yes, the TPS needs to be adjusted. It reads 1 or 2% at idle.

The o2 sensor takes about 10-30 seconds to start working from a start. If you get a datalog where the car stalls after the o2 sensor starts working then we can see if it is flooding or something similar.
Hondata

perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

Re: EP3 stalls after getting gas. evap code

Post by perspective » Thu Oct 30, 2014 6:22 pm

Any updates on this, I still have the same exact issue . When I fill up it stalls for a minute or two, is like the evap system is always on and is choking on the fresh fuek fumes.

perspective
Posts: 22
Joined: Mon Oct 21, 2013 1:50 pm

Re: EP3 stalls after getting gas. evap code

Post by perspective » Wed Nov 12, 2014 4:35 pm

I did calibrate mine , I changed almost every part of the evap system thinking it was my ep3 . The car still stalls only after fill ups. I've noticed that if I don't fill the tank all the way it helps a "bit", it still stalls though. I tried different calibrations from other ep3's with similar mods and didn't help.

User avatar
Spunkster
Site Admin
Posts: 17772
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: EP3 stalls after getting gas. evap code

Post by Spunkster » Wed Nov 12, 2014 5:18 pm

Please start you own thread as this issue appears to have been resolved back in may and was not a software or ECU bug. You may want to try sending the original poster a private message.

ep3steeze
Posts: 12
Joined: Thu May 01, 2014 7:55 am

Re: EP3 stalls after getting gas. evap code

Post by ep3steeze » Wed Jan 20, 2016 12:18 pm

Just an update for anyone with this problem. This WAS due to a software update. Once I updated my KPRO to the latest update, The check engine light and problem have gone away. I did not replace a single thing other then updateded the software on the ECU. Hope this helps anyone else out.

Post Reply