Exocet/KMiata Swap Install Questions

K-Series Programmable ECU installation questions / support issues
Post Reply
jwagner
Posts: 3
Joined: Tue Jun 19, 2018 4:05 pm

Exocet/KMiata Swap Install Questions

Post by jwagner » Wed Jun 20, 2018 12:41 pm

Greetings,

I'm installing a K20A2 into a Miata-based Exocet with a KMiata swap kit. This changes things a bit as it's not a plug-and-play type of swap - I had to do a bunch of manual wiring to get things connected.
-Vehicle: Exomotive Exocet with K20A2, KMiata adapter harness.
- KPro V4 SN 45189, Firmware 11.00, SW 4.3.5.0
- ECU 37820-PND-A56, KManager IDs ECU as "Type PRB - US RSX Type S"

The ECU is installed and communicating with the KManager software. Calibration uploads work, and I can turn the fuel pump on with the "Always On" option. I have not tried to start the car (no fuel yet), although the engine turns over when the key is turned to START.

What I'm having problems with or not understanding:
- Reading sensor screen, IAT and ECT are reading 32 degrees. Stock Honda IAT/ECT sensors.
- Again on sensor page, TPS stuck at 0%. I have traced wiring and the TPS has Vcc/Ground and the sensor varies between .3v and 4.6v depending on throttle position, so that looks right.
- Battery voltage on same screen reads 0V

I am assuming that with the ignition in the ON position (which the ECU recognizes) that these values should read the actual temps, TPS position, and battery voltage, correct?

Arno
Posts: 41
Joined: Sun Sep 02, 2012 8:41 am
Location: The Netherlands

Re: Exocet/KMiata Swap Install Questions

Post by Arno » Wed Jun 20, 2018 10:23 pm

Are pressing F10 first to start datalogging with the ignition ON and Kmanager declaring the ECU as 'online'?

Only then will the sensor data be updated/'live' in the sensor list and any dash templates.

Bye, Arno.

jwagner
Posts: 3
Joined: Tue Jun 19, 2018 4:05 pm

Re: Exocet/KMiata Swap Install Questions

Post by jwagner » Thu Jun 21, 2018 6:32 am

Thank you!! The sensors are being read and with the exception of the IAT reading about 30 degrees F too high, everything looks good.

Now I need to find a tune to get a 12.5 to 1 normally aspirated engine started up.

Jim

jwagner
Posts: 3
Joined: Tue Jun 19, 2018 4:05 pm

Re: Exocet/KMiata Swap Install Questions

Post by jwagner » Mon Jun 25, 2018 7:23 am

Swapped the K20 sensor for a '94 IAT and the temp values look much more realistic. Put a couple gallons of E85 in the tank, turned the key, and it runs!

Need to sort out a bunch of stuff, but got past a huge milestone this weekend.

Post Reply