Upload and erase failures

K-Series Programmable ECU installation questions / support issues
Post Reply
Cyco
Posts: 3
Joined: Sat Oct 27, 2018 4:59 am

Upload and erase failures

Post by Cyco » Sat Oct 27, 2018 5:28 am

- what vehicle you have
1991 Honda Civic with k20a2 & 6 speed trans with k20a3 engine harness
- serial number of your K-Pro
40327
- version of software being used (from Help, About)
Version 4.3.6.0
- ECU part number (starts with 37820) and serial number (the number under the part number)
37820-PNF-A03
2091-305414
- KManager version (not 'the latest')
v.4.3.6 - updated from within kmanager itself
- the calibration (as an attachment)
tuned k20a2 basemap modified for 1000cc injectors and 4 bar map sensor
- a datalog of a problem (as an attachment)
No datalog as cannot upload/start car
- anything about the car which has been modified from stock which may affect the ECU (don't include what sort of rims you have nor stereo etc).
wiring of car is fairly stripped out, really only light wiring left.
- when and where you got the K-Pro
Bought 2014/2015 from Garagefive in Richmond Canada
- a specific description of the problem

Car is fairly stripped out (only have lights left really) using the hybrid racing universal conversion harness. I have had this car running with k20a3 and k20a2 previously. Built a forged K20a2 engine to run a Rotrex c38-91 charger so I have changed to 1000cc injectors and 4bar speed factory map sensor. Car now also has skunk2 intake and throttle body, k-tuned hal-effect tps.

I was turning the car over with the injectors unclipped to circulate the oil before my first start. Then i connected my laptop to kpro as this was a newer version it asked to update the firmware I clicked yes. The progress bar started but i do not recall confirmation of completion or success. I then tried to upload the new basemap without much luck as I had then discovered kmanager was saying - driver installed, online, ign off (even though the key was in the on position. I removed the ecu cover and discovered that the green led was not on and the red led flickering very dim. at this point I tried unplugging and reconnecting the usb cable. When I did this I would get a 1 second flash of the green led then it would go out, then 1 solid flash of the red led then dim flickering of the red led.

Tried to look over the wiring at the time and didn't have much success. Went back to the car today to discover that a wire had come out of the c101 plug. I figured out where it came from and reconnected it. Kmanager then stated driver installed, online, ign on. The green led would still only give a 1 second flash when the usb cable is connected but now the red led flashes a bit brighter.

So at this point I tried to upload the new cal, saw a progress bar that stopped part way and stated upload failed. tried again after unplugging and reconnecting the usb cable with the same result. Tried to erase ecu without any luck pop up stating failed.

At this point im running out of ideas, the ecu will let me kind of datalog (if I open kmanager without any kal loaded it will show a map that has the injectors at 1000cc) if I download it shows a kal with the 1000cc injectors.

So I connected the injectors and tried to start the car, it turned over but did not even hiccup or burp as if was getting fuel or spark.

Where should i go from here? What should I try? Did the kpro firmware update fail?

One of the bigger hurdles now is 2 years ago I moved from Vancouver Canada to the UK so taking the ECU/Kpro to Garagefive in richmond isn't ideal.

Cyco
Posts: 3
Joined: Sat Oct 27, 2018 4:59 am

Re: Upload and erase failures

Post by Cyco » Sat Oct 27, 2018 5:40 am

Another bit of information is when I initially was going to upload the new kal and when the firmware updated the battery voltage was low (so low the started would not do anything). If I remember correctly this may have been when kmanager was attempting to update firmware.

Today when I sorted the wire that pulled from the harness the battery voltage was 12.7-12.65 volts.

Thanks,
Chris

Cyco
Posts: 3
Joined: Sat Oct 27, 2018 4:59 am

Re: Upload and erase failures

Post by Cyco » Sun Oct 28, 2018 8:42 am

All sorted now.

ECU Pin a2 did not have battery voltage (it only had 2 volts)

Sorted another wiring problem and uploaded and started the car fine.

-Chris

Post Reply