No injector Pulse

K-Series Programmable ECU installation questions / support issues
Post Reply
Wo2m
Posts: 7
Joined: Thu Dec 28, 2017 11:25 pm
Location: Santa Clara, CA

No injector Pulse

Post by Wo2m » Tue Oct 30, 2018 5:20 pm

- 05 Lotus Elise w/ k24a2 swap
- Kpro v4 SN - 44700
- version # 4.3.5.0
- ECU PN 37820-PRB-A06
- SN#2068-601824 OK13
- 1300cc injectors

Car started a week ago, had a horrid idle. chased down a vacuum leak and some other issues.

went to restart, no injector pulse. I have spark, i have compression, noid light shows no pulse and spark plugs are dry. will start and "idle" with starting fluid.

no codes, no other issues to speak of. changed no wiring from the time it started.
Kmanager shows a 7ms pulse, but its not showing at the injectors. 12vdc at the injector plugs, continuity checked from injector to ecu.


its possible, that i could have swapped my tps and map, so i changed and tested the map sensor.
also changed the crank angle sensor just incase.

I tried a new calibration, also resetting the kpro with fresh Kal.

is the ecu dead? i have no idea why i would have spark, no codes and no injector pulse. unfortunately i have no other cars around to test it on.
Attachments
nostart.kdl
(739.88 KiB) Downloaded 7 times
nostart.kal
(163.09 KiB) Downloaded 6 times

User avatar
Hondata
Site Admin
Posts: 8410
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: No injector Pulse

Post by Hondata » Wed Oct 31, 2018 9:30 am

Be careful using voltage to diagnose wiring issues because normally you will see +12V on both side of the injector plug.

Do you have fuel pressure? Are the injectors firing at all?
Hondata

Wo2m
Posts: 7
Joined: Thu Dec 28, 2017 11:25 pm
Location: Santa Clara, CA

Re: No injector Pulse

Post by Wo2m » Wed Oct 31, 2018 10:02 am

I have pressure, noid light shows no pulse. Spark plugs are dry, will start and run with starter fluid.

*edit* thanks for the reply.

User avatar
Spunkster
Site Admin
Posts: 17206
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: No injector Pulse

Post by Spunkster » Wed Oct 31, 2018 11:10 am

Is the fuel pump priming?

Wo2m
Posts: 7
Joined: Thu Dec 28, 2017 11:25 pm
Location: Santa Clara, CA

Re: No injector Pulse

Post by Wo2m » Wed Oct 31, 2018 11:18 am

Yes, fuel pump primes.

User avatar
Spunkster
Site Admin
Posts: 17206
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: No injector Pulse

Post by Spunkster » Wed Oct 31, 2018 3:49 pm

You really need to try to find someone that you can try this ECU in a known working vehicle to see if the problem is with the ECU or in the vehicle. If you find the ECU is damaged you then must determine what in your vehicle has caused it to damage the ECU.

Wo2m
Posts: 7
Joined: Thu Dec 28, 2017 11:25 pm
Location: Santa Clara, CA

Re: No injector Pulse

Post by Wo2m » Wed Oct 31, 2018 4:03 pm

I ordered another kpro. I'll pull the harness and check all the wiring again. Are there any options to mail this ecu into hondata for diagnostics?

Wo2m
Posts: 7
Joined: Thu Dec 28, 2017 11:25 pm
Location: Santa Clara, CA

Re: No injector Pulse

Post by Wo2m » Fri Nov 02, 2018 6:56 pm

Ecu came in, fired right up. Does hondata offer ecu repair or board swapping?

User avatar
Spunkster
Site Admin
Posts: 17206
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: No injector Pulse

Post by Spunkster » Tue Nov 06, 2018 10:13 am

Send an email to support<at>hondata.com with the following and I will issue an RMA and give you further
instructions:

Name:
Address:
Phone:
Email:
Serial#:
Description of problem:

include a link to this thread.

Post Reply