Just about starts, revs to 2500, dies

K-Series Programmable ECU installation questions / support issues
Post Reply
stjohnsafc
Posts: 2
Joined: Sun Dec 23, 2018 12:42 pm

Just about starts, revs to 2500, dies

Post by stjohnsafc » Sun Dec 23, 2018 12:58 pm

2005 Honda Civic Type R (EP3) EDM
Kpro V2 (05007154) on PRB
Kmanager 4.3.6.0

K20a2
Drag Cartel 2.2 Cams
Arias 12.5:1 pistons
Scat Rods
RDX injectors
Ktuned rail
RRC Inlet (70mm)
Skunk2 70mm TB
3" exhaust
Deatchwerks DW65c pump

Fresh build, base map provided by tuner to get car running. Map loaded on to Kpro (Kpro is for RSX so i know the wideband/narrowband is an issue, waiting on a PRA ECU.
Key is turns, takes a good few cranks before it finally catches, starts, revs to around 2500rpm for 10 seconds then slowly dies.
Have calibrated TPS in Kmanager, 0.1 and 104
Checked all plugs and vac pipes, only 1 MIL code, and that is as expected for o2 sensor due to wideband/narrowband

I have recorded a datalog
dying.kdl
(307.46 KiB) Downloaded 13 times
Map
K20-Piston-Drag-Carte-2.2-410-RDX-Basemap.kal
(135.74 KiB) Downloaded 9 times
Any help would be much apreciated

Cheers

Lee

stjohnsafc
Posts: 2
Joined: Sun Dec 23, 2018 12:42 pm

Re: Just about starts, revs to 2500, dies

Post by stjohnsafc » Thu Dec 27, 2018 7:40 am

Anybody?

fonzeka
Posts: 70
Joined: Thu Feb 11, 2016 4:15 am
Location: Sweden

Re: Just about starts, revs to 2500, dies

Post by fonzeka » Thu Dec 27, 2018 5:30 pm

You need to use a correct and working O2 sensor, not sure a PRA calibration works on a PRB ecu either.
Why not get a RSX wideband O2 sensor and keep the PRB ecu you got now?

Post Reply