VTC issues code P0010

K-Series Programmable ECU installation questions / support issues
Post Reply
tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

VTC issues code P0010

Post by tehduckeggs » Mon May 27, 2019 6:13 pm

A bit of back story. I bought a k20a swapped EF last week. I just started the process of getting an E-tune. Once i loaded the tuners base map, the car immediately threw a p0010 code. VTC solenoid malfunction. Previous owned had that code turned off on the tune it had. Even if the car is just keyed on, and not turned over, it will throw the code after clearing it. The car runs and drives fine but VTC stays at zero in Kmanager. Obviously this needs to be resolved before continuing my tune. I've tried just about everything except a different ecu.

04 JDM K20a, stock wiring harness, 02-04 PRB ECU w/ V3 (37820-PRB-A06), 04 JDM PNA solenoid. So far we have:

Serial: 10296

-Removed and cleaned the VTC solenoid / screen.
-Hooked up 12v to the solenoid and it moves freely / functions as intended.
-Confirmed pin B1 and B23 on the harness are pinned correctly. Black/white to pin 1, Blue/white to pin 23.
-Confirmed continuity on both wires from ecu harness to solenoid clip.
-Confirmed ground to black/white pin on solenoid clip.

When you clear the code, it comes back on within 10 seconds of key on and stays on, nothing intermittent. Everything works 100% normal other then this P0010 code.


Any insight would be appreciated.

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Mon May 27, 2019 6:33 pm

I typed the pinout incorrectly. B1 is Blue/white and B23 is Black/white like its suppose to be.

Another question i had was does the JDM PNA VTC solenoid work with a USDM ECU? Is there any compatibility issues there?

User avatar
Spunkster
Site Admin
Posts: 18026
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: VTC issues code P0010

Post by Spunkster » Tue May 28, 2019 9:27 am

Have you tried disabling the error like it was in the calibration that did work?

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Tue May 28, 2019 9:37 am

Spunkster wrote:
Tue May 28, 2019 9:27 am
Have you tried disabling the error like it was in the calibration that did work?
Yes. I can disable the P0010 code like it was before, and it wont come back on. But that doesn't help with the fact that VTC does not work.

The previous owner believed that the JDM K20A did not have VTC function (it does), so he had iVtec disabled within the Kpro parameters, which explains why the CEL wasn't on previously. We are trying to take advantage of the benefits that tuning the VTC system provides the K series platform, and have been unable to do so due to this CEL being present.

User avatar
Spunkster
Site Admin
Posts: 18026
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: VTC issues code P0010

Post by Spunkster » Tue May 28, 2019 1:35 pm

It sounds like the ECU may be damaged. You can try the ECU on a known working vehicle and if VTC still does not work then it will need to be replaced.

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Tue May 28, 2019 2:00 pm

Spunkster wrote:
Tue May 28, 2019 1:35 pm
It sounds like the ECU may be damaged. You can try the ECU on a known working vehicle and if VTC still does not work then it will need to be replaced.
I'm going to try and throw my ECU in a known working 03 RSX Type S tonight. It already has a Kpro in it as well. If this does end up being an issue with the ECU. I'm assuming there will be a RMA process?

User avatar
Spunkster
Site Admin
Posts: 18026
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: VTC issues code P0010

Post by Spunkster » Tue May 28, 2019 3:08 pm

Yes, but you would have to provide a working ECU and there would be charges for swapping it.

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Tue May 28, 2019 5:46 pm

Spunkster wrote:
Tue May 28, 2019 3:08 pm
Yes, but you would have to provide a working ECU and there would be charges for swapping it.
Does the inside of this ECU look alright? The discoloring has me a bit worried even though I’ve seen worse.

https://imgur.com/gallery/OIM6pOX

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Sat Jun 01, 2019 6:34 pm

Well. Just tried my ecu in another rsx and it never threw the p0010 code. Back to the drawing board.

thomasn
Posts: 17
Joined: Thu Aug 30, 2018 1:33 am

Re: VTC issues code P0010

Post by thomasn » Sun Jun 02, 2019 8:53 am

Had the same on my engine, the intake cam was physically fixed to 0° because the previous ECU managing the engine was not VTC ready (and intake cam was 20° off on the timing chain to simulate VTC so i had another code also).

So check under the pulley / inspect the mecanism ?

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Sun Jun 02, 2019 5:41 pm

thomasn wrote:
Sun Jun 02, 2019 8:53 am
Had the same on my engine, the intake cam was physically fixed to 0° because the previous ECU managing the engine was not VTC ready (and intake cam was 20° off on the timing chain to simulate VTC so i had another code also).

So check under the pulley / inspect the mecanism ?
Did it stay at 0 no matter what? Kmanager acts like it’s not even seeing the solenoid. Acts exactly the same when the solenoid clip is plugged in or not. Continuity is good from ecu to solenoid clip and almost no resistance. It’s pinned / wired correctly.

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Tue Jun 04, 2019 5:33 pm

Tried a working solenoid in my motor. Still getting the p0010 code within 10 seconds of clearing it in the key on position or when the car is running.

The only thing we haven’t done so far is ran new wires to the solenoid from the ecu harness.

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Wed Jun 05, 2019 7:23 pm

Ran wires new wires directly from b1 and b23 tonight. Ecu connector to solenoid clip. Still getting an immediate p0010 code. Whether you start the car or just key it on. Tried three different vtc Solenoid’s as well. Same results every time. Cam angle never moves from 0 and never has.

We pulled the valve cover off. Vtc cam gear looks fine.

Not too sure where to head next.......

tehduckeggs
Posts: 11
Joined: Mon May 27, 2019 5:59 pm

Re: VTC issues code P0010

Post by tehduckeggs » Thu Jun 06, 2019 6:20 am

Spunkster wrote:
Tue May 28, 2019 3:08 pm
Yes, but you would have to provide a working ECU and there would be charges for swapping it.
How can I tell if this ecu has been modded for an 05-06? Would I have additional issues on top of the p0010 code using it on an 04?

User avatar
Spunkster
Site Admin
Posts: 18026
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: VTC issues code P0010

Post by Spunkster » Thu Jun 06, 2019 10:12 am

Post a picture of the bottom of the ECU circuit board.

Post Reply