KPro 4 possible HF noise issue

K-Series Programmable ECU installation questions / support issues
Post Reply
na94
Posts: 3
Joined: Sun Aug 11, 2019 11:32 am

KPro 4 possible HF noise issue

Post by na94 » Sun Aug 11, 2019 1:29 pm

We've been having an issue with out K24 swapped Miata running a KPro 4.

Under various conditions (seems somewhat random, but mostly noticeable in 2nd gear), we are experiencing an engine hesitation / misfire.

We have triple-checked fuel pressure, and that has been ruled out. This issue is either mechanical or electrical. Here are some images of datalogs showing the problem. It shows up between 11s and 15s in this log. We thought that it was related to lateral acceleration, but I don't believe that it is.

Note the sawtooch pattern in the RPM signal, accompanied by the MAP signal and injector output. This is a brand new MAP sensor (we also had the same problem with a 2nd new MAP sensor) and we installed a brand new Honda engine wiring and charging harness when assembling the car.

The VTEC pressure and VTEC signals all look to be high (1), so that is ruled out.

I am suspecting some sort of HF RF interference and electrical noise. Has anyone seen something similar, or have any suggestions? Our next step is to try and dismount the ECU and secure it in a way that is will not receive any HF vibration.

Injector outputs and the raw data log will follow in a reply.
Kmiata-HF-Noise-Ignition-Timing.PNG
Kmiata-HF-Noise-Ignition-Timing.PNG (18.88 KiB) Viewed 171 times
Kmiata-HF-Noise-ECT+IAT.PNG
Kmiata-HF-Noise-ECT+IAT.PNG (10.66 KiB) Viewed 171 times
Kmiata-HF-Noise-Cam-Angle.PNG
Kmiata-HF-Noise-Cam-Angle.PNG (28.64 KiB) Viewed 171 times
Kmiata-HF-Noise-AFR+MAP.PNG
Kmiata-HF-Noise-AFR+MAP.PNG (13.9 KiB) Viewed 171 times
Kmiata-HF-Noise-VTEC.PNG
Kmiata-HF-Noise-VTEC.PNG (20.52 KiB) Viewed 171 times
Last edited by na94 on Sun Aug 11, 2019 1:33 pm, edited 1 time in total.

na94
Posts: 3
Joined: Sun Aug 11, 2019 11:32 am

Re: KPro 4 possible HF noise issue

Post by na94 » Sun Aug 11, 2019 1:31 pm

Injector outputs:
Kmiata-HF-Noise-Injectors.PNG
Kmiata-HF-Noise-Injectors.PNG (17.31 KiB) Viewed 170 times
Raw data log is attached.

Here is a video of the autocross lap. Sustained issue starts around 13s relative to the lap timer:

https://youtu.be/bAI3XGS16KA
Attachments
KMiata-HF-Noise-VCMC-Cup-5-Run-8.kdl
(3.43 MiB) Downloaded 7 times

User avatar
Spunkster
Site Admin
Posts: 17850
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: KPro 4 possible HF noise issue

Post by Spunkster » Mon Aug 12, 2019 10:20 am

The first step would be to try this ECU in a known working vehicle and see if there are any issues. If not then you need to start looking at wiring issues that could cause this.

na94
Posts: 3
Joined: Sun Aug 11, 2019 11:32 am

Re: KPro 4 possible HF noise issue

Post by na94 » Mon Aug 12, 2019 12:23 pm

I'm concerned about how we have the ECU mounted, so our next test is to dismount it, wrap it in some sort of material that will dampen most of the vibration, and test.

Post Reply