ELD d10 not working! can only use d14 primary o2 sensor

s300 and SManager software questions & answers
forevertrj
Posts: 134
Joined: Mon May 12, 2014 4:13 pm
Location: Victoria BC
Contact:

Re: ELD d10 not working! can only use d14 primary o2 sensor

Post by forevertrj » Thu Mar 08, 2018 8:42 pm

BACK FROM THE DEAD! problem solved! This may be an issue for me only though so don't get your hopes up. This is a solution if someone is having an issue where your car will start and run for about 4-5 minutes or until warmish, then won't start no matter what you try. Today I was poking around in my pinouts, removed my wideband from the D10 plug to see if she would run! Fired it up closed loop on the stock O2 sensor. after a bit I wanted to try open loop again, as soon as I did it worked for 30 seconds then died. what the F! i mean come on! turns out after taking the ECU out of the case and putting it back in I didn't tighten the brass bracket for the transistor or mosfet at the back of the case near the plugs, see picture! whatever this is controlling just right shit the bed when trying to run the car. As soon as I bolted the brass bracket down and it cooled off I've had no further issues!
Attachments
P06-CHIPPED-ECU-2T.png
P06-CHIPPED-ECU-2T.png (293.72 KiB) Viewed 335 times
Let's not make assumptions, please leave as much detail as possible!

Post Reply