Rpm surges in closed loop but not open

s300 and SManager software questions & answers
Post Reply
boosted crx-r
Posts: 53
Joined: Sat Aug 26, 2006 9:27 pm

Rpm surges in closed loop but not open

Post by boosted crx-r » Tue Aug 16, 2016 6:47 pm

I can hold the throttle at 2000 rpm in closed loop and it surges about 600rpm difference but as soon as I switch to open loop while holding the pedal steady it smooths out and no longer surges. Could this be my wideband o2 going bad or something else?
shut up and boost it!

User avatar
Spunkster
Site Admin
Posts: 17992
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Rpm surges in closed loop but not open

Post by Spunkster » Wed Aug 17, 2016 9:22 am

look at your long and short term fuel trims when doing this and you will probably see what is happening.

boosted crx-r
Posts: 53
Joined: Sat Aug 26, 2006 9:27 pm

Re: Rpm surges in closed loop but not open

Post by boosted crx-r » Wed Aug 17, 2016 5:47 pm

can you take a look at the trims and give me any recommendations on which way to go? these datalogs are while im in nuetral holding the throttle at a 2000rpm. it looks like a roller coaster in closed loop,

Aebs 84.5mm sleeves with typer head skunk 2 pro series valve train edelbrock intake and throttle body

heres the tune. i just started messing with it so i know its not perfect
black hatch.skl
(41.95 KiB) Downloaded 59 times
datalog in closed loop with wideband
closed loop.s3d
(118.74 KiB) Downloaded 81 times
open loop
open loop.s3d
(153.77 KiB) Downloaded 57 times
Last edited by boosted crx-r on Wed Aug 17, 2016 6:52 pm, edited 1 time in total.
shut up and boost it!

boosted crx-r
Posts: 53
Joined: Sat Aug 26, 2006 9:27 pm

Re: Rpm surges in closed loop but not open

Post by boosted crx-r » Wed Aug 17, 2016 5:56 pm

it also does the same thing at any rpm level while im driving. makes the car surge
shut up and boost it!

User avatar
Hondata
Site Admin
Posts: 8771
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Rpm surges in closed loop but not open

Post by Hondata » Thu Aug 18, 2016 7:22 am

Your problem is the wideband is slow to respond. With the closed loop datalog graph the lambda & short term trim. The lambda lags the short term trim by around 0.7 seconds. Normally the lag will be 0.2s or less.
Ideally you should find out why the wideband is slow, but you could try reducing the closed loop rate of change values so that short term trim changes more slowly.
Hondata

boosted crx-r
Posts: 53
Joined: Sat Aug 26, 2006 9:27 pm

Re: Rpm surges in closed loop but not open

Post by boosted crx-r » Thu Aug 18, 2016 8:21 am

Ok...I will give that a shot. Is there a point where lowering the short term adjustment will start harming anything on the tune. Would I essentially be running in open loop if the values are set to low? I am running an old box style plx m300 so as you suggested it might be wearing out on me.
shut up and boost it!

User avatar
Hondata
Site Admin
Posts: 8771
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Rpm surges in closed loop but not open

Post by Hondata » Thu Aug 18, 2016 10:10 am

The disadvantage is that the trim will be slow to make any fuel corrections. Pull the o2 and clean it in white vinegar for an hour or so. Otherwise replace the o2, but wideband lambdas are so inexpensive now you might consider a new wideband.
Hondata

boosted crx-r
Posts: 53
Joined: Sat Aug 26, 2006 9:27 pm

Re: Rpm surges in closed loop but not open

Post by boosted crx-r » Thu Aug 18, 2016 5:20 pm

Should I change the slow rate of change or the fast rate of change boxes? Bought a new O2 but it didn't help. Gonna get a new wideband now I guess
shut up and boost it!

User avatar
Hondata
Site Admin
Posts: 8771
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Rpm surges in closed loop but not open

Post by Hondata » Fri Aug 19, 2016 8:32 am

Try one, then the other, and see what gives the lowest short term trim over a couple of seconds.
Hondata

Post Reply