Vtec Spool CEL - B18c P28

s300 and SManager software questions & answers
Post Reply
Lyle_57IAL
Posts: 131
Joined: Wed Jul 25, 2012 5:42 pm

Vtec Spool CEL - B18c P28

Post by Lyle_57IAL » Thu Sep 22, 2016 2:18 am

Hello there Hondata !

Currently have a B18c Type Are Turbo in a 92-01 Dc2 Type R. Running a P28 S300 with a wiring loomb converter. Latest Smanager & Firmware.

Having some strange issues with the car throwing a VTS CEL 21 (Vtec Spool). Vtec will engage no problem but around 500 - 1000 rpm after will hit an engine cut and latch the CEL 21 VTS. I have tried two different Vtec Solenoid Actuators (On the same Vtec solenoid body) both with the same problem.

In the VTEC tab there is the "Disable Vtec Spool Check box". Once this is checked the car will run fine and wont throw the CEL.

However i need some clarity to weather this is simple a Software / Firmware bug that can exist with the massive variety of P28s - OR is this a real problem existing somewhere around the Vtec engagement.

Map is attached.

Thanks in Advance

Regards Lyle :)
Attachments
20161921 - Dc2r Turbo.skl
(43.24 KiB) Downloaded 64 times

User avatar
Spunkster
Site Admin
Posts: 18080
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Vtec Spool CEL - B18c P28

Post by Spunkster » Thu Sep 22, 2016 9:33 am

Is VTEC actually engaging when the VTEC spool error is disabled?

Lyle_57IAL
Posts: 131
Joined: Wed Jul 25, 2012 5:42 pm

Re: Vtec Spool CEL - B18c P28

Post by Lyle_57IAL » Thu Sep 22, 2016 3:54 pm

Yes of course. It will engage when the error disable is both checked and unchecked

Difference is when it's unchecked it throws the CEL, when it's checked it drives as per normal (vtec still engages (easily hear it) tables switch etc)

Any advice ?

User avatar
Spunkster
Site Admin
Posts: 18080
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Vtec Spool CEL - B18c P28

Post by Spunkster » Thu Sep 22, 2016 4:06 pm

I would recommend that you try a different ECU as the one you have may be damaged in some way.

Lyle_57IAL
Posts: 131
Joined: Wed Jul 25, 2012 5:42 pm

Re: Vtec Spool CEL - B18c P28

Post by Lyle_57IAL » Fri Sep 23, 2016 12:41 am

Spunkster - i would like to know if this will potentially cause any harm to OR allow a harmful condition to occur by disabling the vtec spool CEL

Cheers

User avatar
Spunkster
Site Admin
Posts: 18080
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Vtec Spool CEL - B18c P28

Post by Spunkster » Fri Sep 23, 2016 9:27 am

If it is giving strange errors and behavior, something is not right. If it were me I would not use that ECU and use one that worked correctly to avoid any future problems.

Lyle_57IAL
Posts: 131
Joined: Wed Jul 25, 2012 5:42 pm

Re: Vtec Spool CEL - B18c P28

Post by Lyle_57IAL » Fri Sep 23, 2016 8:13 pm

Why Does hondata give the option available to disable the error in the Vtec Tab ?

Lyle_57IAL
Posts: 131
Joined: Wed Jul 25, 2012 5:42 pm

Re: Vtec Spool CEL - B18c P28

Post by Lyle_57IAL » Mon Sep 26, 2016 2:18 am

Spunkster wrote:If it is giving strange errors and behavior, something is not right. If it were me I would not use that ECU and use one that worked correctly to avoid any future problems.
Spunkster - This is not a quality response that of what i would expect from a vendor / manufacture.

What is the condition that triggers the Vtec Spool CEL ? As i said before in my situation vtec on the car engages / holds in place no problem. It throws the CEL when the error box is unchecked and has done this on two different Solenoids.

In some way is this related to the circuit resistance when the solenoid is activated?

Post Reply