Page 1 of 1

S300 V1 - No sensor information displayed when datalogging

Posted: Sun Aug 20, 2017 4:09 pm
by h10ndr

I'm new to Hondata (previously used NeptuneRTP) and have a problem. I hope its me being stupid, but here goes...

I have a fresh P28 ecu socketed professionally for Boost and S300. I installed the S300, no problems there straightforward.

Its now fitted in the car with a previously used obd2a - obd1 harness and the s300 connects/works fine. I can upload maps and download fine, I can even datalog. However, with our basemap (B20VTEC TURBO) uploaded the car is cranking but wont start so I tried to datalog, and the sensors do not record any values at all (rpm,tps etc). I can download the datalog and its just a recording of sensors reading zero mostly.

If I connect to the s300 and hit datalog button I should see at least revs/tps/map values move in the displayed sensors right?
What am i doing wrong? The engine has just been installed, primed for first start, it turns over and there is a spark (white ? weak)
Plz plz help.

The S300 is a version 1 but was brand new (SERIAL# S300-12,584) and not used before, the ecu is also a overhalled 11F0 board made to P28 equiv with boost components added.

Re: S300 V1 - No sensor information displayed when datalogging

Posted: Mon Aug 21, 2017 10:30 am
by Spunkster
Has J12 been cut in the ECU? What are the lights on the s300 board doing?

Re: S300 V1 - No sensor information displayed when datalogging

Posted: Wed Aug 23, 2017 2:04 am
by h10ndr
Thanks for the reply...

Yes, J12 is missing I checked.

Update: I've got to the bottom of this, and its relating to the dreaded red light (low battery) problem. I wasn't even aware of this design flaw in the ver.1 S300. Pretty poor I must say, and wouldn't have paid good money for it, I thought I was getting a deal.

Anyway, I hadn't noticed the lights in the ecu until I was working in the dusk. If we leave the ecu connected and the cars ign on for a few mins the light goes green, and then I can datalog fine. The hondata works as I expected all along and I can see all the live sensor data. However, once I disconnect from the ecu, when we try turn the ign on again the green light on the hondata board only lasts for about 10-20mins before we get red. I suspect this means the car would run ok until it is switched off, and left for any length of time and then not start until the calibration is uploaded again.

Although this ver1 unit is brand new and sealed in its box (bought used), it must have been sat for some time (years?) After some research I found the battery life in these NVRAM chips should only power up on first use, so I am shocked to find its nearly dead already. Some small fuses in the chip blow on first connection and the battery circuit is connected and then the count down begins.

So, I managed to datalog our attempts at a first start, and found the generic 3 bar maps sensor we bought isn't calibrated correctly (where do I get the settings?) or is faulty. We were getting off the chart map readings (10+psi) on cranking and the map was using -4 degrees of timing to try start the car!! So tonight we are refitting the stock map sensor and updating the calibration to use stock map sensor to try start the car again...

If we get it started today, then we will be forced to buy another S300 or get my local electronics firm to replace the NVRAM chip and try save the S300 v1 and resell to get something back. I have read on the internet of people fixing their S300 v1 with a replacement NVRAM chip so I haven't given up hope regardless of what Hondata state. I believe this is where the calibration etc is retained on the board. Just not sure if we need to copy the chip first or just try replace it.

Re: S300 V1 - No sensor information displayed when datalogging

Posted: Wed Aug 23, 2017 9:45 am
by Spunkster
Those chips have been discontinued for many years and are no longer available. Any you find will most likely be counterfeit and give you the same issues. Your best solution would be to upgrade to the new v3 s300 which does not have any battery backup and should never have this type of issue.

Re: S300 V1 - No sensor information displayed when datalogging

Posted: Wed Aug 23, 2017 1:11 pm
by h10ndr
Thanks again for advice.

Just want to get the car started before we invest in a new one. However I have hit a wall with the SManager software.
I suspected the 3 bar map sensor we bought is faulty or we dont have the correct settings for it, so tonight we went back to a stock honda map sensor. Changed the parameter for MAP to Stock and when datalogging the map sensor displays -0.4" with just ign on and when we we try to start the car the timing is being read from column 6-7 which is wrong. In frustration having tried another stock map sensor and getting the same, I adjusted the timing in those columns to 18' timing and the car started but run rough and would barely idle.

I think I altered the units to mbar from the default "/psi at some point and wondered if the scaling values had not altered/converted. So I loaded a stock GSR basemap and put the units back to "/psi and again the ign timing was reading from the mid to high table columns and not the first few columns, again would not start.

What is going on?

Re: S300 V1 - No sensor information displayed when datalogging

Posted: Wed Aug 23, 2017 4:59 pm
by Spunkster
I would stop trying to troubleshoot until you have a properly working s300 as you may be troubleshooting a non-issue that is all caused by the faulty s300.

Re: S300 V1 - No sensor information displayed when datalogging

Posted: Wed Aug 23, 2017 11:30 pm
by h10ndr
Seems to work fine once we upload the calibration though. We have green light.?