Page 1 of 1

flashpro connects and locks to fn2 , wont upload or unlock

Posted: Sat Jan 21, 2012 4:03 am
by ef9b16a1
- serial number of your FlashPro = FP-SI-INT21407 ,bought fom the greek dealer as always , two days ago

- FlashPro Manager version = AND , tried both , now on ,tried three different laptops

- the calibration = wont upload any cal , either mine or those included by hondata

- a datalog of a problem = its an upload issue , i only have the pics that follow

- what sort of vehicle you have = civic type-r edm fn2

- what sort of ECU you are using = stock that came with the car

- anything about the car which has been modified from stock which may affect the ECU = header and exaust

- a specific description of the problem
flashpro connects to laptop OK ,drivers and flashpro icons are active
flashpro connects to laptop and vehicle ok , all icons active (driver, flashpro , ecu , obd2 )
flashpro connects to hondata for registration and locks to vehicle ok
everything looks normal as everytime ,datalog works ok

i cant upload any file either to the car or flashpro , even if flashpro is disconnected from the vehicle , it shows an error message
this one

the upload bar appears for half a second , and then the above message appears..
BUT fpmanager states tha LAST UPLOAD WAS SUCCESFUL!!!!!!!!! even if there is no cal loaded in the flashpro ''calibrations'' tab , or the car of course
after trying with three laptops , win xp and win 7, and two software versions and , i felt confident that its was a flashpro problem...

SO , i decide that i cant hassle the customer that lost his appointment , and the dyno..
and i call the dealer so i can get a replacement flashpro , and let him get an rma etc

BUT , now , THE FP will not UNLOCK from the vehicle
since therewas no cal loaded , i press unlock , but it prompts me to return the car to stock (i guess fp thinks an upload was made , or during lock the stock cal is stored in the fp i dont know)
i choose return to stock to load the stock cal back to the car (even if there was no cal actually ever loaded in the car)
the upload bar appears again for half second and dissapears, with no error message , then i press UNLOCK , and it prompts me again to RETURN TO STOCK , THAT of course i cannot do.....
and thats it.. i cannot unlock it whatever i try (laptops , power cycles, restarts etc)

so i am now stuck with a flashpro that is NOT working , and that i have to pay to the dealer , and i cannot even unlock it from the car , to return it back.. and get another

car battery voltage was 14.1-14.3 immidietely after start up and 11.7-11.9 when i tried to upload , have done it with less than 11.7 many times before

car has the stock cal in , and moves , customer left with it... fortunately!!!!

CAN i use another flashpro to the same vehicle , if the old one in not unlocked??
i mean using a new unlocked flashpro , will OVERWRITE the lock?
Ι guess i can , the fp locks to the ecu , and not the ecu to the fp
so i can tune the car until the matter is resolved

its definitely a fp problem , since i cant upload with the car disconnected , but how will i unlock it ,when i press unlock it prompts to press return to stock , and return to stock of course doesnt work

i guess if the customer reported the fp stolen , i would also end up in prison :-)

thank you

Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Sat Jan 21, 2012 6:14 pm
by engjoo
I see that your firmware for the flashpro unit is 40.

40 comes from v1.2.0 onwards. Have you tried using v1.2.2 which is the current version?

Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Sat Jan 21, 2012 8:17 pm
by ef9b16a1
when you plugin the fp in a new soft version and there is a new firmware update available , it prompts you to upgrade , as soon as u plug it in the usb
nothing happens when i plug this particular fp unit , and i cant see a manual update firmware option...
can i force a firmware update?

other than that ,. the unit should be able to upload and downlod cals without beeing plugged to the car even then..

i once had upgraded fp firmware in a new fpm version that was released , but didnt re upload the cals to the fp unit , i uploaded them to my car fine... but the car wouldnt start...
but the upload function worked ..

i am confident its the units fault , i just need a confirmation from hondata , on what to do with the ''unlock issue''
if i return it to the dealer and its not unlocked , hondata mighht think its stolen or something , and not replace it..
so if i tune the car with another fp unit that the delaer will give me , i guess i ll overwrite the unlock , but what will happen with this fp unit? i need to get an rma?
thats my concern , i dont want the dealer that has already paid for the not beeing able to return it back to hondata
its not his fault , and definitely not mine or the customers..


Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Sat Jan 21, 2012 10:11 pm
by engjoo
I think you current sw cannot work with this firmware which is a newer version.

As I do not know of anyway to downgrade the firmware, you may have to upgrade the software to 1.2.2 instead.

Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Sun Jan 22, 2012 6:59 am
by ef9b16a1
to the beta version???? u d be kidding

its not my car , its customers cars , i cannot risk that.. unless hondata tells me its the stable version
when i press check for updates , and is the current version , there is no NEW version , for a customers car..
in my car i d try anything , thats another story

i am not trying to solve the problem , there is no problem , the fp unit is faulty..
all other units i tried upload and download in the fp , cals from ANY software version... plugged in laptops with
the only thing i want is to unlock it from the vehicle some way , so it doesnt get wasted

Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Sun Jan 22, 2012 8:38 am
by Hondata
engjoo is correct - the firmware version indicates that this must be used for the FlashPro. The latest software version is

Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Sun Jan 22, 2012 10:24 am
by ef9b16a1
So I have to use the beta version ? I can't go back from that firmware

Re: flashpro connects and locks to fn2 , wont upload or unlo

Posted: Mon Jan 23, 2012 12:28 am
by ef9b16a1 fixed the problem..

i wouldnt have tried that not even in 20 years.. since the software identifies as the latest version to download...

i guess i got fp units of the latest batch , that have to work only with
will have that in mind

thanx for the help..

i didnt bother to check if the included cd had or 1.2....