Page 1 of 1

Weird Idle Since 2.4.2

Posted: Wed Jun 01, 2016 6:14 pm
by bigbadspoon
I've had a weird idle thing happening since I installed 2.4.2 and uploaded a new cal.

When I let off the throttle and drop the car into neutral, the RPM drops more quickly than normal, to about 900, then overreacts to get to about 1500, then back to 900, up to 1400, etc losing about 100-200 RPM each time until settling around 1000 RPM. I also noticed that the throttle plate now stays open at 4-5% during idle, giving me MAP pressures of about 29-30kPa, where it used to idle at 2% throttle with MAP pressures around 27 kPa. Consequently, the injectors now rest at about 3ms, where they used to be 2.7.

Was there any stealth update in 2.4.2 that could have caused this kind of behavior? If so, is there an easy way to downgrade FP manager back to 2.3.7 when it was last working properly (aside from the VTC PID)?

I uploaded my last full calibration (1.12, when idle was working properly) and a calibration I made last night using that one as the base (1.15d, tuning low cam WOT). I've also attached datalogs for both.

I've also tried turning off throttle pedal overrun, by setting the Trim % to -100% and unchecking the "overrun throttle opening enabled". It made the car a little jerky, but no effect on the idle.

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 02, 2016 4:08 pm
by Spunkster
How long have you driven it this way between reflashes?

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 02, 2016 5:18 pm
by bigbadspoon
I drive to and from work every morning for about 20 minutes each trip, roughly 50% city, 50% highway. Since I've been tuning my VTC tables, I've reflashed almost every day for the last couple weeks (since May 18). This idle behavior only started after updating to 2.4.2 on May 28th.

Re: Weird Idle Since 2.4.2

Posted: Fri Jun 03, 2016 9:12 am
by Spunkster
Don't reflash it for a few days and see if the idle learn corrects this.

Re: Weird Idle Since 2.4.2

Posted: Wed Jun 08, 2016 5:35 pm
by bigbadspoon
I've had the same tune on for 3 days now and the problem is only getting worse. Now when I pop into neutral, the idle pops down to like 1k, bounces to 1500, then slowly revs to 2000 before cutting the fuel and starting over. It's like it knows that it's time to idle, but can't figure out how.

I notice that the ignition timing is not following a standard idle map where it would default to 0 or 8 degrees advance. It's floating from like 15-40 degrees advance in these conditions. When the RPM ramps it roughly correlates to the spark advance ramp.

During this whole thing, I can see TPLATE moving from 3-5% correlating with the increases in manifold pressure. There's something telling the plate to move during this event.

In datalog0000 at 17:50, you can clearly see this behavior until about 18:10.

Also, I've noticed that it feels more twitchy on light throttle than it used to. By that, I mean the point *right* before where the injectors shut off. That transition point feels super rough compared to where it was, and my overrun and injector dead time settings are all the same as they used to be.

Lastly, I've noticed my fuel trims climbing *super* high since updating to 2.4.2. What used to be LTFT 0, STFT between -2 and 2 is now LTFT 6 and STFT 7-10. I'm wondering if there's a problem with the "Use MAP fuel tables" checkbox, telling my car to run MAP all the time, even though I set the "minimum pressure for speed/density" to 94 kPa (WOT).

The calibration I attached is what I've been running for the last 3 days.

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 10:06 am
by Spunkster
What throttle body are you using?

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 3:15 pm
by bigbadspoon

My mods are:
RV6 Downpipe
Magnaflow catback

I haven't done any hardware mods in almost 2 years aside from my headlights, so this recent activity should be isolated from that. I haven't even opened the hood since January, when I changed the oil.

I ran the same AFM cal for almost a year, but I got a wild hair in mid-April and decided I wanted to really get the most out of my car by tuning the VTC tables and going through the AFM calibration with a new statistical model I found. It was going well until this issue and the VTC PID thing popped up.

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 3:35 pm
by bigbadspoon
I guess for more background on my calibration and how long potentially relevant variables were set stably.

Throttle plate map -OK for 2 years
15.7:1 AFR -OK for 2 years
Injector dead times -OK for 2 years
MAP to determine WOT-OK for 2 years
Overrun fuel cut -OK since April
Use MAP fuel tables
Min pressure 94kPa -OK from May 8 until updating to 2.4.2? Maybe still OK. Not sure how to test.

Recently changed items:
Fuel/spark low/high 97 and 103 kPa columns
VTC low/high
VTC PID (tuned with step inputs while parked in the driveway)

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 4:08 pm
by Spunkster
We tested your calibration on our own 2012 SI and it idled properly without any issues.

Have you tied a stock calibration?

We also noticed you have non-stock dead times for your injectors, why is this?

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 5:01 pm
by bigbadspoon
I changed the dead times a few years ago because I was having a problem with the fuel trim drifting over the course of 20-30 mins worth of highway driving. I spoke with someone expertly knowledgeable on the subject and when we set the dead times where they are the problem basically went away.

I actually just tried the "stock equivalent" calibration and had the same idle problem, though.

I went a pulled the intake tube off the car to see if the throttle plate was dirty or something, but it's completely clean.

I'm having a hard time getting behind this as a mechanical issue, though, when it was running perfectly when I got home, then doing this after a reflash.

I appreciate you guys checking the cal on your car, but the symptom doesn't happen just idling. It happens idling while the car is moving. Like, if I'm going 50, then put it in neutral to coast down to a stop sign. When I finally stop the car, it settles to a normal idle within 2-3 seconds. Same for when I first start it up and back out of the driveway.

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 5:03 pm
by bigbadspoon
Actually, I'm looking through my "stock equivalent" calibration datalog and there's no way it's the stock equivalent since it's still running at 15.7:1. I had it in the secondary slot on my FP and probably flashed it wrong. I'll put it in the primary slot and try again...

Re: Weird Idle Since 2.4.2

Posted: Thu Jun 09, 2016 5:16 pm
by bigbadspoon
I put in the "stock equivalent" calibration and ran a lap around my neighborhood. The problem was *way* worse. I attached a log below.

Not sure what's going on.

Re: Weird Idle Since 2.4.2

Posted: Fri Jun 10, 2016 9:12 am
by Spunkster
We tested as you described with moving and then coasting down with no problems. You appear to have some other issue happening since it does not do this on a stock vehicle.

You might try putting your stock intake back on and use the stock equivalent calibration with that.

Re: Weird Idle Since 2.4.2

Posted: Fri Jun 10, 2016 2:48 pm
by bigbadspoon
So, I kind of hate myself for posting this, since I thought this was basically a made-up thing after trying to fix other cars' idle problems with it to no avail...

I ran the idle relearn procedure and it seems to have fixed the problem (only driven it for about 5 mins since running the procedure). I guess it just happens that something bumped off my idle on the same day I updated FP.

Will keep you posted if it comes back, but I'm hoping it's fixed for good. Thank you guys for taking the time to flash your car and drive it around. It definitely helped narrow my investigation.

Re: Weird Idle Since 2.4.2

Posted: Fri Jun 10, 2016 5:03 pm
by Spunkster
Thanks for letting us know