2018 Accord 1.5 clutch slip

FlashPro questions & answers specific to the 2008+ Accord, Americas and international
Post Reply
ajgarcia
Posts: 8
Joined: Sun Jul 01, 2018 7:08 pm

2018 Accord 1.5 clutch slip

Post by ajgarcia »

Is anyone else out there getting any clutch slip with the stage 3 tune?

I know it come with the territory of the tuner (especially since I've got 42.5k miles), but it's not consistently slipping and wanted to see if anyone else has experienced it.

ajgarcia
Posts: 8
Joined: Sun Jul 01, 2018 7:08 pm

Re: 2018 Accord 1.5 clutch slip

Post by ajgarcia »

Update: for some weird reason, after a reflash, I have not had anything that seems like clutch slip. Really weird, but just wanted to let anyone who viewed this post know. Either I'm totally crazy or the ECM may have been interfering (which is probably not the case at all)

User avatar
Spunkster
Site Admin
Posts: 18159
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: 2018 Accord 1.5 clutch slip

Post by Spunkster »

The EU itself will have nothing to do with the clutch as it is mechanical. If you make too much torque or abuse the clutch it may slip.

andyswmr714
Posts: 15
Joined: Thu Jan 24, 2019 7:57 pm

Re: 2018 Accord 1.5 clutch slip

Post by andyswmr714 »

You definitely need a clutch. A modified stage2 tune will cause slippage too during high load.

I now have modified stage3 tune and FX400 Sprung clutch and clutch masters light weight flywheel.

The clutch now definitely holds the torque. Picked up over at PRL.

hybridspl
Posts: 2
Joined: Fri Dec 27, 2019 8:09 pm

Re: 2018 Accord 1.5 clutch slip

Post by hybridspl »

I have been a Honda tech for 20+ years and have owned nearly 40 tuned Honda's and am having a strange "slipping" issue too. 1.5 with stage 2 and an AEM intake. Never beat on the car and never even spun the tires as it is my daily and I take the kids to school in it. It will just "slip" during 3rd and 4th gear. I added the HASport mounts (worth every penny) and the issue has been reduced, but still occurs. I am going over my tune now and trying to datalog things, because I suspect it may be traction control/knock control related. It doesn't totally feel like a slipping clutch, but that's the closest description I can come up with. Did you ever resolve your issue?

Post Reply