Skunk2 CAI and FlashPro

2012+ US/Canadian Civic Si / 2013+ ILX
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

Hey I went out and test drove my car and I was able to recreate the instance. It's located in the last 30 seconds or so of the datalog attached.
datalog0018.fpdl
(1.24 MiB) Downloaded 17 times
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Joshua97 wrote: Wed Apr 20, 2022 12:16 pm What did you think it might be? Were you able to see what was causing the issue in the datalog I sent to you? I'm going to give it a test drive now. I'll let you know how it goes! Thanks!
From the way you described it, it sounded like the ECU was transitioning in and out of open loop on medium throttle pressure. Since you're at such high elevation, your WOT is essentially part throttle for a car closer to sea level because the manifold pressure is so much lower. Therefore, I thought maybe you were straddling some weird manifold pressure transition. It wasn't though.
Joshua97 wrote: Wed Apr 20, 2022 1:23 pm Hey I went out and test drove my car and I was able to recreate the instance. It's located in the last 30 seconds or so of the datalog attached.
datalog0018.fpdl
Interesting. Has it done this the whole time, or has is come up recently? I'm also seeing some weird idle fuel trims too in the past two datalogs. Try going back to Rev01.1 again and let's see how a datalog looks on that one. I'm curious to see the idle trims, and see if you can recreate the issue with that revision again.
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

No it hasn't been doing this the whole time. It only started with the most recent calibration. And it's not all the time either. It's super random and inconsistent. I'll datalog Rev01.1 for you tonight and send it over. Hopefully I can't recreate the issue but we'll see. Thanks!
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Sounds good, no you hope you can't recreate which means we're on the right track. Haha. But yeah, we'll see what you get.
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

So bad news. I was able to recreate the issue not once but I think 3 or 4 times in the span of about 20 seconds or so. I have it attached in the datalog below for you to look at. It's in the last minute or so of the datalog. Hopefully we can figure out what's going on. Do you think it's related to the tune or mechanical with what you've seen so far?
datalog0021.fpdl
(450.72 KiB) Downloaded 17 times
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Interesting, only the fact that it happened after a few revisions does it make me think it might be mechanical. That datalog was really short so I didn't get to see much of the idle data that looked a little odd in the last few revisions. Let's try a completely different file, if the issue persists we'll have to look over everything mechanically and perhaps regroup a little bit. But take this one for a spin and see if you can recreate it.
Joshua97.SD.Rev01.2 (Blended)(Vtec4500).fpcal
(23.68 KiB) Downloaded 19 times
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

Hey I downloaded the calibration you provided and I took a datalog for you. I was still having that issue using this one so it's definitely something mechanical related. My guess is maybe fuel injectors? Is there any way to look at a datalog and know for sure? Here's the datalog for you to look at.
datalog0023.fpdl
(4.37 MiB) Downloaded 17 times
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Interesting, yeah it would be difficult to find via a datalog honestly because we don't have individual cylinder data, only aggregate from all cylinders. I'll look over the datalog a little more and see if I can find anything though, and study it a little more. The fact that it came on after a few files and won't go away does make me agree it might be something mechanical.

I put together one for test for you. This is a Hondata basemap, take it for a drive and see if you can recreate it. If so, then it's definitely something mechanical and we will go from there.
Joshua97.HondataTest.fpcal
(22.04 KiB) Downloaded 21 times
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

Hey I took it out for a test drive using the basemap you provided and so far I haven't been able to recreate the issue. I'll try again tomorrow to see if I can get it. If not then maybe it is the tune after all? I'm not sure what's different between the basemap and the tunes you've provided.
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Sounds good. Just let me know.
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

Ok sounds good. Aside from this issue we're you able to get the car tuned correctly with the CAI in the other calibrations?
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Yeah I've tuned more 9th gens that I can remember with these types of intakes. As yours was good, then the issue came about after a couple revisions which is strange. The data looks good on yours overall, except for where you have the issue of course. Well even there the data looks fine in the fuel tables, but in the timeline of the datalog I can see the fuel going weird. If you can't replicate the issue with the Hondata basemap, I will use that and tweak it as best I can without changing any major settings.
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

Yeah I've tried everything and I can't replicate the issue at all with the basemap so I'm not sure what could be causing the issue in the other calibrations. Sorry to keep sending you data logs and for taking up so much of your time. I really appreciate all the help you've been.
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Skunk2 CAI and FlashPro

Post by EFICU »

Okay, post a datalog with the current calibration so I can work on that one. I'll try to add the features from the other calibrations to make it run solid, but stay away from those that might be causing the issue.
Joshua97
Posts: 32
Joined: Tue Apr 12, 2022 7:27 am

Re: Skunk2 CAI and FlashPro

Post by Joshua97 »

Sorry for the late response but here's a datalog with the current calibration. Let me know if you need a longer one.
datalog0027.fpdl
(1.76 MiB) Downloaded 19 times
Post Reply