Radiator Fan Control

s300 and SManager software questions & answers
Locked
dpetro1
Posts: 19
Joined: Mon Sep 01, 2008 10:06 pm

Radiator Fan Control

Post by dpetro1 »

trying to troubleshoot my rad fan control. i am running 1.3.8 and using AUX1 to control the rad fan.

so i click "generic output" then...
-input tab "always on"
-output tab a12 FANC
-parameters

RPM 0-10000
Load -3 - 20psi
Min MPH - 0
Min throttle - 0
Min air temp - 1
ECT 185 - 260

problem is the fan just comes on as soon as i turn the key to "on". i want it to come on at 185 as listed in parameters.

i wired my relay fo the fan and assume its correct since the fan works, it just doesnt follow my ECT instructions. Do i have something wrong in smanager?
User avatar
Hondata
Site Admin
Posts: 9477
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

Can you post the calibration? You'll want to set the minimum load to something much less than -3 psi.
Hondata
dpetro1
Posts: 19
Joined: Mon Sep 01, 2008 10:06 pm

Post by dpetro1 »

doh!!! when i converted psi to hg i was using mmHG not inHG so i thought -3psi had me covered. ill try something like -20psi (-40''hg) and see if that cures it. ill report back on saturday when i get back to the car.

EDIT: hmm actually im not sure that would explain my problem. maybe if the fan wasnt coming on at all. since the min load wasnt met.

i am using a SPST relay. should i be using a SPDT instead?
dpetro1
Posts: 19
Joined: Mon Sep 01, 2008 10:06 pm

Post by dpetro1 »

calibration uploaded
Attachments
danny petro 30r 185 fan.skl
(38.72 KiB) Downloaded 82 times
User avatar
Hondata
Site Admin
Posts: 9477
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

1. On the input uncheck 'Invert Input'. An arming input that is always on then inverted is never on. Uncheck the other 'Disable' boxes too.
2. On conditions set minimum rpm to 100, and minimum engine load to -14 psi.
Hondata
dpetro1
Posts: 19
Joined: Mon Sep 01, 2008 10:06 pm

Post by dpetro1 »

Hondata wrote:1. On the input uncheck 'Invert Input'. An arming input that is always on then inverted is never on. Uncheck the other 'Disable' boxes too.
2. On conditions set minimum rpm to 100, and minimum engine load to -14 psi.
no dice. the fan will only come on when i check "invert output" and the key is at "on" position. any other suggestions?
User avatar
Hondata
Site Admin
Posts: 9477
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

'Invert input' or 'invert output'?
Hondata
dpetro1
Posts: 19
Joined: Mon Sep 01, 2008 10:06 pm

Post by dpetro1 »

Output. regardless of what i change in the input tab or conditions tab the fan comes on when i check "invert output" and turns off when its unchecked
tiamat6x3
Posts: 13
Joined: Tue Nov 25, 2008 11:32 am

nitrous / aux control

Post by tiamat6x3 »

Has anyone figured this one out? I have this same exact problem. I have tried the parameters stated above by hondata site admin but it will not turn the fans on. I know the computer has the capability to control the fan because if I check the "invert output" button it will turn the fans on but they will just always be on no matter what.

I have this same problem with nitrous control. I cannot get it to function based on parameters. Only on or off with the invert output button.

I have a p72 ecu (I think, 94 integr GSR)

Any help would be greatly appreciated.
User avatar
Spunkster
Site Admin
Posts: 19350
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata

Post by Spunkster »

You cannot have an engine speed of 0, it must be something above 0
tiamat6x3
Posts: 13
Joined: Tue Nov 25, 2008 11:32 am

Post by tiamat6x3 »

slick, that did the trick thanks.

Will it ever change it to be able to have the engine speed to 0? its useful to be able to test these things w/ out the engine running.
dpetro1
Posts: 19
Joined: Mon Sep 01, 2008 10:06 pm

Post by dpetro1 »

LOL i thought this thread died. i should have checked back sooner. i just figured this out on my own today and was coming back to post my findings.

spunkster hwere were you a few weeks ago? :D
Locked