Search found 6 matches

by j_cvstillo
Tue Sep 25, 2018 4:58 pm
Forum: s300 / SManager
Topic: B20V Turbo Running Very Rich
Replies: 2
Views: 226

B20V Turbo Running Very Rich

Set Up: Stock B20B block Gsr Head with Head Package Stock Cams 1000cc Bosch Injectors 70mm VMS TB 4Bar Map Sensor Aftermarket Fuel Pressure Regulator 450 Walbro Pump Hondata CPR Kit 66mm Ebay Turbo Just about 2 months ago I got the car tuned, everything ran fine for a little until I started blowing ...
by j_cvstillo
Sun Sep 16, 2018 1:02 am
Forum: Coil Pack Retrofit
Topic: New CPR kit, hard crank. No start up!
Replies: 2
Views: 355

Re: New CPR kit, hard crank. No start up!

“Transistor” sorry
by j_cvstillo
Sun Sep 16, 2018 12:49 am
Forum: Coil Pack Retrofit
Topic: New CPR kit, hard crank. No start up!
Replies: 2
Views: 355

New CPR kit, hard crank. No start up!

I installed a brand new cpr kit. I wired it up according to hondata. Power A25, Ground A23, ICM A22, Sync A16, ground on the thermostat housing, Tac & 12v power on the distributor. My problem is that I’m cranking the car it’s only cranking and not turning over. Power light and ignition light turns o...
by j_cvstillo
Tue Sep 11, 2018 4:41 pm
Forum: Coil Pack Retrofit
Topic: Installed CPR KIT, RE TUNE?!!
Replies: 2
Views: 312

Re: Installed CPR KIT, RE TUNE?!!

thanks a lot!
by j_cvstillo
Tue Sep 11, 2018 2:02 am
Forum: Coil Pack Retrofit
Topic: Installed CPR KIT, RE TUNE?!!
Replies: 2
Views: 312

Installed CPR KIT, RE TUNE?!!

I just purchased a CPR kit to upgrade from the stock ignition system. My car is already tuned and i was wondering if I will I have to re tune again? I'm hearing that I'm supposed to tune the car again after installation
by j_cvstillo
Tue Sep 04, 2018 10:57 am
Forum: s300 / SManager
Topic: B20V Turbo (Rich and Lean Issues)
Replies: 1
Views: 166

B20V Turbo (Rich and Lean Issues)

Lately I've been having issues. My car was tuned by Felix (Gato) Medina about 2 months ago in New Jersey and i always had a problem with the car running rich. I changed my fuel pressure regulator and set it 45 psi, AFR was reading 11.8 and then I brought it up to 50 psi and it read 12.0 to 12.5 and ...