Speedometer not working in 2006 RSX with K-pro

K-Series Programmable ECU installation questions / support issues
Post Reply
QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

Hi guys!

I posted this in CRSX thinking I might have been doing something wrong, but then Spunkster mentioned that my ECU was not modified for 05+...


K-pro sn: 05004189
ECU pn: 37820-PRB-A04
ECU sn: 2068-300338 0G11
Car is 2006 type s turbo

I bought a turbo'ed 2006 RSX Type s with a bad ringland. The car has and was tuned on K-pro, has the jumper harness (grey plug) and the label on the side of the ECU stating that it has been modified to work with 05+.

Swapped the motor, car runs and drives fine. I can connect to the ECU with Kmanager just fine. Everything works on that end, have countershaft VSS enabled and it reads correct via Kmanager and OBDII, but nothing to the cluster. All other gauges work except speedo and odometer. Fuel gauge is abnormally sluggish, not sure if that's related or not, and of course, cruise doesn't work.

K-pro board is legit as far as I can tell. I'll attached some pictures so you can see what I'm looking at. Help is appreciated, really need to get this working ASAP.

Thanks,
dp
Attachments
image3.jpg
image3.jpg (133.8 KiB) Viewed 2804 times
image2.jpg
image2.jpg (115.45 KiB) Viewed 2804 times
image1.jpg
image1.jpg (135.22 KiB) Viewed 2804 times
image.jpg
image.jpg (119.33 KiB) Viewed 2804 times

Axix23
Posts: 132
Joined: Fri Sep 21, 2007 10:09 am
Contact:

Re: Speedometer not working in 2006 RSX with K-pro

Post by Axix23 »

post up the kal your running. Did you enable the counter shaft sensor option for 05-06 rsx?

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

Yes, countershaft option is checked. Speed is correct in K-Manager and through OBDII. ECU has correct speed, it's just not making it to the cluster.

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

I can post the Kal later, but I don't think it will really help. seems to be more of a hardware issue?

User avatar
Hondata
Site Admin
Posts: 9005
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Speedometer not working in 2006 RSX with K-pro

Post by Hondata »

That ECU was not prepared for use in an 05/06 RSX.
Hondata

User avatar
Spunkster
Site Admin
Posts: 18413
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Speedometer not working in 2006 RSX with K-pro

Post by Spunkster »

It appears that someone may have put a sticker on it and used someone else's harness. Can you take high quality in focus pictures of the bottom and top of the ECU circuit board (all screws will need to be removed for this) and post them here.

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

Sure, I'll get this as soon as I'm off work.

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

Ok, this is the best I could get with my phone. Let me know if you can see what you're looking for.
Attachments
Bottom View.jpg
Bottom View.jpg (712.79 KiB) Viewed 2788 times
Top View.jpg
Top View.jpg (669.83 KiB) Viewed 2788 times

User avatar
Spunkster
Site Admin
Posts: 18413
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Speedometer not working in 2006 RSX with K-pro

Post by Spunkster »

ITs hard to make out, can you take a closer picture of the inside of the ECU showing the lower half with the ECU plugs and about 2 inches above that.

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

This little guy?
Attachments
image.jpg
image.jpg (293.43 KiB) Viewed 2782 times

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

If that's not what you are looking for, just draw a circle or something around the area you need in my above pics. I can focus on that area then.

User avatar
Spunkster
Site Admin
Posts: 18413
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Speedometer not working in 2006 RSX with K-pro

Post by Spunkster »

No, that is the bottom of the ECU. I need a better picture of the top of the ECU specifically the half closest to the ECU connector.

QuickWrench
Posts: 8
Joined: Sat Jun 21, 2014 8:17 am

Re: Speedometer not working in 2006 RSX with K-pro

Post by QuickWrench »

Might be a little huge. Hopefully this is what you need.
Attachments
image.jpg
image.jpg (1.46 MiB) Viewed 2779 times

User avatar
Spunkster
Site Admin
Posts: 18413
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Speedometer not working in 2006 RSX with K-pro

Post by Spunkster »

It does not appear to have the correct circuitry needed to have the speedometer work in an 05. Since we have no record of this ECU being converted for use with an 05 this makes sense.

Send an email to support <at> hondata.com with the following and I will issue an RMA and give you further
instructions (include a link to this thread):

Name:
Address:
Phone:
Email:
Serial#:
Description of problem:

Post Reply