Big Kpro problem

K-Series Programmable ECU installation questions / support issues
Locked
jopanet
Posts: 8
Joined: Fri Aug 17, 2007 7:51 am
Location: chicagoland
Contact:

Big Kpro problem

Post by jopanet » Fri Aug 17, 2007 7:55 am

I got Kpro for my RSX Type S 06 a few months ago and 2 weeks after I got it threw some code P0181 so I reset the ECU and car ran fine, then 2 months later same code came back, reset it and car's fine, now my car took a total sh1t!!! It barely starts, the immobilizer is flashing, check engine light is on, speedo doesnt work and neither does the water temp gauge, runs like total crap and idles very rough at around 1k. I disconnected the battery just now trying to see if this will help for an hour and it didnt help.

ps. Also I have a brockway engineering gizmo that reads codes, well it wont even read anything at all!!!!!

User avatar
Hondata
Site Admin
Posts: 8813
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata » Fri Aug 17, 2007 9:16 am

http://www.hondata.net/forum/viewtopic.php?t=3629

Check grounds. Check grounds. Check grounds.
Hondata

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Post by Spunkster » Fri Aug 17, 2007 9:31 am

Also try opening Kmanager, going to online , tools and click on clear security. After you have cleared the security, tun the ignition off and back on, then go to File, New and choose a brand new calibration form the list (choose the 05 calibration), and then upload that to the ecu. See if the car will then start.

jopanet
Posts: 8
Joined: Fri Aug 17, 2007 7:51 am
Location: chicagoland
Contact:

Post by jopanet » Fri Aug 17, 2007 10:08 am

Thanks for the replies. I checked the grounds and they are fine, I even relocated the ground from the top of the valve cover back to the intake manifold and that didnt help. I dont have access to a laptop right now, so I will try and get it hooked up on monday.

The serial number of the kpro is 2121.

jopanet
Posts: 8
Joined: Fri Aug 17, 2007 7:51 am
Location: chicagoland
Contact:

Post by jopanet » Sat Aug 18, 2007 3:06 pm

can I put the stock ECU back in?

jopanet
Posts: 8
Joined: Fri Aug 17, 2007 7:51 am
Location: chicagoland
Contact:

Post by jopanet » Sun Aug 19, 2007 3:00 pm

I hooked up the ecu to a laptop and was able to connect to the kpro. Attempting to upload a calibration resulted in Upload failure error. Downloading it results in getting a bunch of garbage like a 16000 rpm redline.. I ecu finally sort of came back to life, where my speedo is now working and so is immobilizer and so is the water temp gauge and it no longer dumps black smoke out of the muffle. Howerever the check engine light is on and I cannot rev past 4k. My brockway engineering R920 retrieved DTC P0181. Just like the previous 2 times!!!! What the hell is going on?

El Verdugo
Posts: 49
Joined: Fri Dec 08, 2006 6:08 pm
Location: Port Allen
Contact:

Post by El Verdugo » Tue Aug 28, 2007 1:34 pm

So any luck on this? Is the car sorted out or still giving you issues?

jopanet
Posts: 8
Joined: Fri Aug 17, 2007 7:51 am
Location: chicagoland
Contact:

yes

Post by jopanet » Wed Aug 29, 2007 11:16 am

the issue was resolved, the person that had sold me the kpro examined it and found a loose resistor, or some other circuit element and repaired it, I got the kpro back and uploading/downloading works great and no CEL or any of that sort so far... so it came down to the electronics in the ECU/Kpro, what I had suspected all along.

Slip_Angle
Posts: 78
Joined: Wed Apr 11, 2007 8:26 pm

Post by Slip_Angle » Tue Nov 06, 2007 7:50 pm

My 02 Civic SiR with K24a2 swap is seeing this problem now too. This morning I started the car and got the P0181 code on my Brockway R920. I cleared the code three times without shutting of the car and it would always come back immediately. I then cleared the code and shut the car off. The code has not come back since.

If this is at all related to the previous posters problem, is it possible there is a cold solder joint or something that only shows up when it's cold? It's hovering around 0 here now (32F).

Advise?

02547 Serial #
Stock Kpro'd 02 Civic SiR (Canada) ECU
1.2.2.9 - Just upgraded from the previous version while checking the serial #
No Problems uploading calibration.

Engine swap was done in late spring and no problems have been encountered until today.

G101 ground is attached to the stud on the cyl head.
Attachments
2.K24A2-TODA.kal
(47.5 KiB) Downloaded 31 times

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Post by Spunkster » Wed Nov 07, 2007 10:33 am

I would suggest using the Kmanager software for reading error codes andclearing them instead of some other piece of hardware. P0181 is not a Honda error code.

Locked