Idle problem when upgrading from 1226 to 1227

K-Series Programmable ECU installation questions / support issues
Postradomis
Posts: 5
Joined: Sat Mar 03, 2007 6:39 pm
Location: NJ
Contact:

Idle problem when upgrading from 1226 to 1227

Post by Postradomis »

This morning i upgraded to the newest version 1227....i noticed my idle drops down to around 300rpm's and then hops up to 1200rpms and stays between that and 1100rpms.

The idel isn't irratic at all...its steady.

I uploaded the 1226 version with the same cal and the idel went down to the lower to mid 800's and is steady. My laptop died before i could record any datalogs. I'll post them tonight.

Any ideas?
Hopeless Confinement

User avatar
Hondata
Site Admin
Posts: 8881
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

Can you post a datalog of each version?
Hondata

Postradomis
Posts: 5
Joined: Sat Mar 03, 2007 6:39 pm
Location: NJ
Contact:

Post by Postradomis »

i reinstalled 1227 and it's running fine now :oops:

thanks for the speedy response tho 8)
Hopeless Confinement

GIFF5323
Posts: 28
Joined: Wed May 31, 2006 3:28 pm
Location: OKC, OK

Post by GIFF5323 »

I had the same thing happen today. I updated to 1227 and when I made a few corrections to the parameters and tables my idle started acting funny. The car warms up and idles around 1100-1300 RPMs but the idle is set at 850 RPMs. If I give it some gas it increases then decreases in a wave type of pattern for three to five cycles then goes back to idling between 1100-1300. I have already cleaned the IAC months ago and it has been idling fine so I definately know its not that and it only started today after I upgraded to 1227. I'll post the datalog from my laptop tomorrow morning so Hondata can take a look at it and see if 1227 has a glitch or something.

Can someone from hondata send me version 1.2.2.6 so I can upload it and see if it does the same thing on the old version and datalog it. Then I can use 1.2.2.7 upload the same Kal and see if it happens like it is now.

GIFF5323
Posts: 28
Joined: Wed May 31, 2006 3:28 pm
Location: OKC, OK

Post by GIFF5323 »

Here is my calibration and datalog on 1.2.2.7.
Attachments
idle problem.kdl
(573.38 KiB) Downloaded 37 times
Original Load Modified.kal
(46.23 KiB) Downloaded 30 times

Black05EP3
Posts: 9
Joined: Tue Mar 14, 2006 10:24 am
Location: Skummyvale, CA

Same issues...

Post by Black05EP3 »

Update from 1226 to 1227
I am also having an idle issue. I re-installed 1227 to see if would help, to no avail.
Car goes from running fine, then the idle starts surging.
EP3
ITR K20a w/JRSC 4.4 pulley
A3 crank pulley
AEM V2 SRI
550cc RC's

Any help would be appreciated.
Attachments
6.kdl
20 days ago was fine
(2.03 MiB) Downloaded 34 times
wtf2.kdl
Now idle surges
(1.15 MiB) Downloaded 33 times

User avatar
Hondata
Site Admin
Posts: 8881
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

If you upload a calibration it erases the idle learn memory. This takes 3 or so dats to relearn. Until then it will not idle correctly. If you have an engine swap, the wiring does not give the ECU backup power and it will never perform the idle learn.

Black05EP3: your short term fuel trim is -20%. That is the problem.

GIFF5323: follow the posting guidelines and provide more information.

Do not downgrade versions of software.
Hondata

Black05EP3
Posts: 9
Joined: Tue Mar 14, 2006 10:24 am
Location: Skummyvale, CA

Post by Black05EP3 »

Hondata wrote:If you upload a calibration it erases the idle learn memory. This takes 3 or so dats to relearn. Until then it will not idle correctly. If you have an engine swap, the wiring does not give the ECU backup power and it will never perform the idle learn.

Black05EP3: your short term fuel trim is -20%. That is the problem.

GIFF5323: follow the posting guidelines and provide more information.

Do not downgrade versions of software.
Thank you Hondata!
I do wonder why this only happened when I upgraded? I have been using this tune since the dyno and I have not altered it, and it always ran fine. I know lees than spit about the in's and out's of K-Pro so I will go back and see my tuner.
Thank you though for the help, and I will post back results.

Christian

GIFF5323
Posts: 28
Joined: Wed May 31, 2006 3:28 pm
Location: OKC, OK

Post by GIFF5323 »

When posting a KPro problem with your vehicle, please include:
- serial number of your K-Pro
PNF ECU
- the calibration (as an attachment)
Already posted
- a datalog of a problem (as an attachment)
Already posted
- what sort of vehicle you have
2002 Civic SI EP3
- what sort of ECU you are using
Stock ECU that was sent to Hondata for K-pro mod
- anything about the car which has been modified from stock which may affect the ECU (don't include what sort of rims you have nor stereo etc).
JRSC - R version
DCSPORTS Header
DCSPORTS CATBACK
Megan Racing Test Pipe
Injen (New) CAI

- a specific description of the problem

I updated to 1227 and when I made a few corrections to the parameters and tables my idle started acting funny. The car warms up and idles around 1100-1300 RPMs but the idle is set at 850 RPMs. If I give it some gas it increases then decreases in a wave type of pattern for three to five cycles then goes back to idling between 1100-1300. I have already cleaned the IAC months ago and it has been idling fine so I definately know its not that and it only started today after I upgraded to 1227.
Last edited by GIFF5323 on Tue Aug 21, 2007 10:34 am, edited 1 time in total.

Postradomis
Posts: 5
Joined: Sat Mar 03, 2007 6:39 pm
Location: NJ
Contact:

Post by Postradomis »

So on the way to work this happend again.

I dataloged the car's idle and its fine until the ECT reaches 177and above.

With 1226 the idle is fine @ these temps.

I use the k20a3 high octane kal w/ obd2 disabled on both.
Attachments
1226IdleECT180.kdl
car's idle w/ 1226
(600.42 KiB) Downloaded 28 times
1227Idle.kdl
the car idles fine until ECT reaches 177and above...
(2.57 MiB) Downloaded 28 times
Hopeless Confinement

GIFF5323
Posts: 28
Joined: Wed May 31, 2006 3:28 pm
Location: OKC, OK

Post by GIFF5323 »

I know that Hondata recommended that I not revert back to 1226 but I had to see if it was something wrong with the car. After a reload of 1226 and a reload of the kal... no idle problems. I then reloaded 1227 and the kal and the idle problem resurfaced. Not sure what to make of that but I hope Hondata does. I also went through about 5 cycles for the relearn process. It took most of the day.

silver rsx-s
Posts: 25
Joined: Tue May 24, 2005 5:51 pm
Contact:

Post by silver rsx-s »

i too am experiencing issues with idle since upgrading

it'll idle fine then start surging, or dip down to like 400rpms and sit there for a second and come back up.....quite annoying

and yeah it erased idle procedures. but i've never had issues when uploading or upgrading with same procedures in the past

civicvtec1ps
Posts: 3
Joined: Sat Dec 27, 2003 7:55 pm
Location: Socal
Contact:

Post by civicvtec1ps »

I want to downgrade.

Im having same issues with idle.
:(
2003 ep3

User avatar
Hondata
Site Admin
Posts: 8881
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Post by Hondata »

Ok, can people post more information - the calibration, type of engine and type of ECU?
Hondata

Black05EP3
Posts: 9
Joined: Tue Mar 14, 2006 10:24 am
Location: Skummyvale, CA

Post by Black05EP3 »

Hondata wrote:Ok, can people post more information - the calibration, type of engine and type of ECU?
05 EP3
ITR K20a swap using A3 harness and knock sensor
PNF ECU A3
JRSC w. 4.4 pulley
A3 crank pulley
550cc RC's
AEM V2 SRI
IDK 22 1 step colder plugs

Datalogs above
Attachments
Christi an FINAL 6-1-07-2.kal
my tune
(44.31 KiB) Downloaded 32 times

Locked