Two questions regarding my KAL... idle and surging

K-Series Programmable ECU Calibration updates / downloads
Locked
ct9ars
Posts: 4
Joined: Thu Oct 29, 2009 8:21 am

Two questions regarding my KAL... idle and surging

Post by ct9ars » Thu Oct 29, 2009 8:24 am

The tune seems to be great at full throttle, made 230whp/160wtq with just IHE on a JDM K20A.

Driveability is a different matter. The car is somewhat jerky at light throttle, say less than 5% TPS, it'll buck back and forth.

The idle also goes down to about 1600 at first, then drops to 1200, and finally the correct 975 when it stops.

Any ideas? Thank you in advance.
Attachments
Teg Shop Initial.kal
(47.01 KiB) Downloaded 258 times

hardcorersxs
Posts: 51
Joined: Mon Apr 11, 2005 3:49 am

Re: Two questions regarding my KAL... idle and surging

Post by hardcorersxs » Tue Nov 03, 2009 11:54 am

ct9ars wrote:The tune seems to be great at full throttle, made 230whp/160wtq with just IHE on a JDM K20A.

Driveability is a different matter. The car is somewhat jerky at light throttle, say less than 5% TPS, it'll buck back and forth.

The idle also goes down to about 1600 at first, then drops to 1200, and finally the correct 975 when it stops.

Any ideas? Thank you in advance.
Your tune needs work. How much you pay for your tune and why are your o2 sensor cel's disabled (only for race engines!!)?

ct9ars
Posts: 4
Joined: Thu Oct 29, 2009 8:21 am

Post by ct9ars » Tue Nov 03, 2009 12:00 pm

It was done by a shop here, LHT along with the swap. The tune was included with the engine installation.

What's wrong with the tune? I thought that only the secondary O2 CEL's were disabled since there is no secondary O2 in the car.

hardcorersxs
Posts: 51
Joined: Mon Apr 11, 2005 3:49 am

Post by hardcorersxs » Tue Nov 03, 2009 12:11 pm

ct9ars wrote:It was done by a shop here, LHT along with the swap. The tune was included with the engine installation.

What's wrong with the tune? I thought that only the secondary O2 CEL's were disabled since there is no secondary O2 in the car.
It's a very generic tune. No lean protection, high cam angle tables look horrible, vtc pt is too high (probably missing some mid-range tq!!!!) I see this too many times. Those CEL's are for the primary and not for the 2ndary.

Where's your dyno graph?

ct9ars
Posts: 4
Joined: Thu Oct 29, 2009 8:21 am

Post by ct9ars » Tue Nov 03, 2009 12:14 pm

I wouldn't mind having it retuned. There aren't many tuners here, maybe one more that I can take it to for the car to get retuned.

I'll turn those two options back on then. Is the tune unsafe, or just not optimized for maximum power/driveability?

It's a road race car so having a dangerous tune could be a problem.

I'll scan the graph when I get home. The power/torque is on par with what it is and the A/Fs seemed decent.
Last edited by ct9ars on Tue Nov 03, 2009 12:18 pm, edited 1 time in total.

ct9ars
Posts: 4
Joined: Thu Oct 29, 2009 8:21 am

Post by ct9ars » Tue Nov 03, 2009 3:11 pm

heres the graph
Attachments
dynotegk.jpeg.jpeg
dynotegk.jpeg.jpeg (309.14 KiB) Viewed 2826 times

Locked