Vacuum increases at 6K, even at full throttle....

K-Series Programmable ECU Calibration updates / downloads
Post Reply
greeenteeee
Posts: 2
Joined: Sun May 21, 2017 10:36 pm

Vacuum increases at 6K, even at full throttle....

Post by greeenteeee » Sun May 21, 2017 10:50 pm

Here's a picture of the log to help.

Image

I've been noticing this for months, the car is not a daily so I have been on and off in trying to diagnose.
Also the car is still drivable, just lacks the benefits of the K20 if it's dying at 6k.

I monitor engine vacuum via kPa. Atmospheric here is 93-94kPa,

I know it'll lose kPa as engine RPM increases, and it is afterall with the stock airbox, BUT at 6,000 RPM,
kPa drops to about 60kPA, CLV drops to about 60%.

There was an OLD post where someone had an issue but their STFT was 26%... mine reads 0% STFT and LTFT as I have it in open loop.

I had the TPS replaced recently, it was dying seconds at a time. STFT/LTFT and primary and secondary voltages looked off, swapped out the primary o2 with a Denso 234-9005, then it ran LEAN... 17-18AFR at cruise, added more fuel then it'd try to stall. Got it home re-installed the original o2 sensor and have another Denso ready if it acts up again.

Currently has the original o2 sensor, I checked the plugs today (which are 2 years old, maybe 5k miles on them MAX). I have tried disabling stock knock logic-- no difference aside from removing all the ghost knocks on fwy and false knocks at take off (knock voltage always below threshold).

I am at a loss, appreciative of help or any suggestions.
Attachments
6k hesi still 2017-05-21.kdl
datalog
(133.21 KiB) Downloaded 31 times
V71.kal
calibration
(165.33 KiB) Downloaded 32 times

User avatar
Hondata
Site Admin
Posts: 8686
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Vacuum increases at 6K, even at full throttle....

Post by Hondata » Mon May 22, 2017 7:47 am

Stop looking at the calibration and look for mechanical causes. Something is either closing the throttle or restricting the intake. In the past I've seen flexible couplings on the intake collapsing which cause this.
Hondata

greeenteeee
Posts: 2
Joined: Sun May 21, 2017 10:36 pm

Re: Vacuum increases at 6K, even at full throttle....

Post by greeenteeee » Sun May 28, 2017 6:59 pm

Hondata wrote:
Mon May 22, 2017 7:47 am
Stop looking at the calibration and look for mechanical causes. Something is either closing the throttle or restricting the intake. In the past I've seen flexible couplings on the intake collapsing which cause this.
I have tried to look at both, no CEL, so no leads.

Restricting the intake makes sense and the effects of the bottle neck stock airbox are shown in WOT kPa values, but it is consistently a 30kPa / 30% CLV drop right around 6k.

Verified today that there is no intake restriction. I took apart the intake system and there was nothing to clog it, last taken apart was about 2 years and <5k miles for IACV cleaning and a brand new OEM air filter.

What else could close the throttle, suddenly, consistently and ONLY at 6k rpm?

I can't see anything wrong with the throttle body-- if there was something closing the throttle, I imagine it'd be a mechanical issue that wouldn't only arise at 6k. Throttle cables aren't binding. Having just replaced the TPS and verified voltages of 0.49V/4.49V, it seems it is working just fine.

Only other thing I can suspect is an engine internal issue, but idle vac and vac in general is healthy.

Post Reply