Target Lambda Issues

s300 and SManager software questions & answers
Post Reply
DaX
Posts: 488
Joined: Tue Mar 18, 2003 3:48 pm

Target Lambda Issues

Post by DaX » Tue Nov 19, 2019 11:00 am

I'm using SManager version 2.7.3.0. For the sake of listing everything, I'm opening a new calibration (stock P28) to test this out. I've got the low speed fuel table pulled up and am looking at target lambda.

The first thing I found is that after making and adjustment, once the settings window closes, the changes don't show up on the target lambda table unless you switch to another table view (delta lambda) and then back to target lambda. After switching back and forth, the target lambda table is updated.

The second issue I found is that when adjusting target lambda values (Options > Settings > Target Lambda) for Low Load Lambda or Medium Load Lambda, if you hit the Enter key the Options window will close and the change is not made, even after switching back and forth from another view. If you make a change to any other variable field on the Target Lambda tab (High Load Lambda, Engine Load Low value, and Engine Load high value) and hit the Enter key the change is made, but you still have to change back and forth between views to see the table update.

User avatar
Hondata
Site Admin
Posts: 8815
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Target Lambda Issues

Post by Hondata » Thu Nov 21, 2019 2:39 pm

Thank you for this report. I've fixed both issues.

Unfortunately I've just released a new version that was built yesterday so the changes will not be in that version.
Hondata

DaX
Posts: 488
Joined: Tue Mar 18, 2003 3:48 pm

Re: Target Lambda Issues

Post by DaX » Fri Nov 22, 2019 7:49 am

Cool, and thanks for fixing it. It's not a huge deal, as long as I click the "OK" button instead of hitting the Enter key, the changes are saved.

Post Reply