B16B ITB with iddle issues

Calibrations for S-Manager - Use all calibrations at your own risk (dyno tuning recommended)
LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

B16B ITB with iddle issues

Post by LeSceptre » Thu Jun 14, 2018 11:54 am

Hi,

I have a B16B with ITB (stock injectors / IACV removed / MAP sensor connected to a vacuum cylinder linked to each TB). Cams are Skunk2 Pro2+. Using Smanager for S300 ECU, we managed to make adjustments to calibration (TPS based) so that the engine is running well while moving (we can get the AFR as targeted) but we still have problems with iddle.

In fact, when the engine is cold iddle is around 1000RPM but when the engine starts to get hotter, the RPM increases progressively. At first, it used to get up to 1800RPM (when hot : I live in French Polynesia and temperature is around 26°C all the time, maximum 32°C -> hot IAT under hood when in direct sunlight), then get down to 1000RPM, then immediately re-increase to 1800RPM, then get down to 1000RPM, etc, etc...

We tried to make some adjustments to the iddle parameters in the calibration (iddle controlled by ignition, etc...) but it wasn't enough so we directly corrected the fuel and ignitions maps at 0% TPS in the 1000/1500 RPM range (reduce fuel and decrease advance). We managed to get the iddle down to 1200RPM but ignition is at -4 !!! and AFR is around 14,7 but is not stable!

Also, I have read a lot of very interesting topics in this forum, tried to adjust the calibration in consequence but still feel there is something wrong. Therefore, I would really appreciate recommendations as I am wondering if the important variations in the ignition MAP may not put to much stress on the engine (-4 to ~22...) and would also like to have advises on how to get the iddle to be smooth at 1000RPM.

MAP sensor is around 0.6BAR throttle fully closed. TPS sensor has been calibrated in SManager and throttle opening checked visually (SManager shows 0% throttle fully closed and 100% throttle fully opened).

Thank you very much in advance for your help and support. (Current calibration is attached ; please do not consider higher TPS/RPM as we are currently focused on the iddle issue and just started this new calibration : higher TPS/RPM not tuned)

Any help would be really appreciated.
Sincerely, LS
map ITB Pro2+ modif LS.skl
(42.85 KiB) Downloaded 43 times

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Fri Jun 15, 2018 11:50 am

Hello,
Any feedback on this issue ? Additional information needed ?
Or maybe this topic is not in the right board and should be post in "Board index s100/s200/s300 s300 / SManager" ?
Thank you very much in advance,
LS

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: B16B ITB with iddle issues

Post by Spunkster » Fri Jun 15, 2018 12:11 pm

You need to post a datalog showing the issue as well.

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Sat Jun 16, 2018 1:57 am

Hi, sorry, I forgot.

So I made datalogs with 3 different progressive maps :

- the first map is a more classic fo fuel and ignition :
TPS1 map.skl
(46.47 KiB) Downloaded 33 times
- in the datalog you can RPM hangs at 1800RPM (and used to go to 1000 then go bac to 1800, etc...) :
TPS1 datalog.s3d
(1.06 MiB) Downloaded 31 times
- the second map is with corrections to iddle parameters (iddle controlled by ignition) :
TPS2 map.skl
(43.35 KiB) Downloaded 35 times
- but as you can see in the datalog the iddle RPM is still at around 1600RPM (not enough correction) :
TPS2 datalog.s3d
(711.89 KiB) Downloaded 31 times

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Sat Jun 16, 2018 2:04 am

- in the last map, I adjusted not only iddle parameters (iddle controlled by ignition) but I also made some adjustments to the ignition and fuel tables :
TPS3 map.skl
(42.85 KiB) Downloaded 31 times
- and in the following datalogs, you can see that engine is staying at around 1000RPM when cold and then raises up to 1200RPM when warming/hot but as explained above I do feel there may be something wrong and I am afraid fuel and ignition tables at low TPS % and RPM may put to much stress on the engine.
- cold :
TPS3 datalog cold.s3d
(5.25 MiB) Downloaded 31 times
- warming :
TPS3 datalog warming.s3d
(689.92 KiB) Downloaded 31 times
- hot :
TPS3 datalog hot.s3d
(1.1 MiB) Downloaded 32 times
Any advise/help would be really appreciated!

Thanks again in advance. Sincerely, LS

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Sun Jun 17, 2018 10:39 am

Hi, any feedback/advise regarding my issue ? Thanks

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Mon Jun 18, 2018 11:50 pm

Hondata, Spunkster and any other tuner expert, any advise, recommendation or feedback on this issue ?
Thanks in advance

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Tue Jun 19, 2018 10:32 pm

So, no feedback, advise or recommendation at all regarding this issue ?
Yet, I noticed calibrations and datalogs have been downloaded...
Help please!

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

B16B ITB with iddle issues

Post by LeSceptre » Thu Jun 21, 2018 9:48 am

Hi,
Please see below topic.
viewtopic.php?f=20&t=21406
Any help would be really appreciated.
Thanks

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: B16B ITB with iddle issues

Post by Spunkster » Thu Jun 21, 2018 11:07 am

It sounds like the itbs are not sealing correctly and more air is getting by when they are "closed". You really need an idle controller that can allow a little air to bleed into the runners in a controlled manner. This is why most people do not run ITBs on street driven vehicles as they do not have characteristics which work well on the street.

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Thu Jun 21, 2018 11:40 am

Hi,

This car is for street and track.

I thought the ITB were getting to much air too. We will resynchronize them.

Besides, I finally managed to get the iddle down to 1100RPM but ignition is at -4 (AFR is around 14,7).

Do you think such change in advance from iddle to moving (-4 to ~+20, etc...) might damage the engine ? Or it is not an issue at all ?

Thank you in advance.

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: B16B ITB with iddle issues

Post by Spunkster » Thu Jun 21, 2018 11:42 am

It could have an adverse reaction.

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Thu Jun 21, 2018 1:52 pm

What do you mean by "adverse reaction" ? Could you rephrase just to be sure to understand you well ?
(Sorry, English is not my mother thongue.)

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: B16B ITB with iddle issues

Post by Spunkster » Fri Jun 22, 2018 9:32 am

It may be bad for the engine

LeSceptre
Posts: 19
Joined: Thu Jun 14, 2018 11:02 am

Re: B16B ITB with iddle issues

Post by LeSceptre » Thu Aug 30, 2018 10:21 pm

Hi,
Why is the ITB basemap TPS table index range from 1 to 40%
How do you adjust/tune iddle (0%) and high load (above 40%) ?
Thank you, Aurèle

Post Reply