k20z3 Help losing power..

FlashPro questions & answers specific to the 2006-2011 Americas Civic Si
Post Reply
Douglas47k
Posts: 2
Joined: Wed Jul 10, 2019 3:36 pm

k20z3 Help losing power..

Post by Douglas47k » Wed Jul 10, 2019 3:51 pm

so i intalled a ktuned short ram intake and the car felt like hesitating and it felt it was loosing power. i drove the car for about a week and then the hondata arrived and it still felt the same. Of course the car feels faster but i am still feeling the car loses power when i press gas....(HELP)
Attachments
datalog0017.fpdl
(66.75 KiB) Downloaded 16 times
Capture.JPG
between seconds 14s-15s the car is going 60mph, then drops down to 51mph then goes back to 57mph, and all of this happens when pressing gas...
Capture.JPG (233.68 KiB) Viewed 456 times

User avatar
Hondata
Site Admin
Posts: 8718
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: k20z3 Help losing power..

Post by Hondata » Wed Jul 10, 2019 4:01 pm

Moved from the KPro section.

Your long term fuel trim is 15% and in the datalog you start to run very lean when you come off the throttle. So the fuel tuning is way off. Are you running mass flow or speed density? Post the calibration.
Hondata

Douglas47k
Posts: 2
Joined: Wed Jul 10, 2019 3:36 pm

Re: k20z3 Help losing power..

Post by Douglas47k » Wed Jul 10, 2019 6:57 pm

i am running mass flow and the calibration i am using is K&N V2 SRI. THANK YOU
Attachments
K&N V2 SRI.fpcal
(21.87 KiB) Downloaded 16 times

User avatar
Hondata
Site Admin
Posts: 8718
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: k20z3 Help losing power..

Post by Hondata » Thu Jul 11, 2019 9:16 am

The intake is leaning things out 25-30%. This is very high so have a look at the intake and make sure everything is aligned correctly. Otherwise it needs tuning.
Hondata

Post Reply