misfire at 3500rpm

FlashPro questions & answers specific to the FN2 European Civic Type R
Post Reply
el colon
Posts: 22
Joined: Wed Jan 16, 2019 1:40 pm

misfire at 3500rpm

Post by el colon » Thu May 30, 2019 10:55 am

Hi there,

I was hoping someone could maybe take a look at the data log file I've attached and let me know if there is anything "wrong" with it.

My car (K20 supercharged Ariel Atom) has started "misfiring" at approx 3500rpm in pretty much every gear, most noticeably in 3rd and 4th. It doesn't do it every time, probably seven out of every ten times that I rev through 3500rpm.

I pulled the spark plugs and this is what they look like:

Image

It feels almost like the fuel momentarily stops flowing, the engine jerks and sometimes there is a loud backfire. I've changed the fuel filter which made no difference, and I also changed the battery as it wasn't holding a very good charge (the Atom uses a very small battery). The injectors are ID1050X and only recently fitted.

If it was an injector issue, I would have thought that the "misfire" would be random, but it's always at approx 3500rpm.

The datalog was made whilst I drove in a manner trying to repeatedly get the car to exhibit the issue, so I'm hoping something has been captured that will mean something to someone who fully understands these logs.

I would really appreciate any help.

Thank you
datalog0003.fpdl
(1000.1 KiB) Downloaded 28 times

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: misfire at 3500rpm

Post by Spunkster » Thu May 30, 2019 11:38 am

What injectors are you using?

el colon
Posts: 22
Joined: Wed Jan 16, 2019 1:40 pm

Re: misfire at 3500rpm

Post by el colon » Thu May 30, 2019 11:43 am

Spunkster wrote:
Thu May 30, 2019 11:38 am
What injectors are you using?
Hi Spunkster,

As above, they are Injector Dynamics 1050X

Many thanks

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: misfire at 3500rpm

Post by Spunkster » Thu May 30, 2019 1:02 pm

Post the calibration as well.

el colon
Posts: 22
Joined: Wed Jan 16, 2019 1:40 pm

Re: misfire at 3500rpm

Post by el colon » Thu May 30, 2019 1:11 pm

Spunkster wrote:
Thu May 30, 2019 1:02 pm
Post the calibration as well.
Unfortunately I can't as the tuner (CPL) refuses to provide it to me, despite leaving me with the rev hang issue as posted about here:

viewtopic.php?f=28&t=22190

They have refused to offer any help with the rev hang issue and now this "misfire" has developed, the only thing I can provide using my Flashpro is datalogs. I am going to have to get my car mapped again (obviously not by CPL) but am reluctant due to the poor experience I've had so far. The Injector Dynamics 1050X were supplied/fitted by CPL when they mapped my car as they told me I needed bigger injectors. I'm concerned in case this misfire will cause engine damage, especially if its some sort of fuelling issue causing the engine to run lean.

Would really appreciate any help you can offer!

User avatar
Hondata
Site Admin
Posts: 8761
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: misfire at 3500rpm

Post by Hondata » Fri May 31, 2019 8:01 am

You don't have a working o2 sensor. Looking at the lambda would be a good start.

Without the calibration we can't do anything.
Hondata

el colon
Posts: 22
Joined: Wed Jan 16, 2019 1:40 pm

Re: misfire at 3500rpm

Post by el colon » Fri May 31, 2019 11:34 am

Hondata wrote:
Fri May 31, 2019 8:01 am
You don't have a working o2 sensor. Looking at the lambda would be a good start.

Without the calibration we can't do anything.
Thank you very much indeed, really appreciate that. I'll investigate the lambda sensor.

Can I ask how you can tell that from the datalog, is that something I can do myself? If I know how to read the data log to check the lambda, I can fit a new one and recheck a fresh data log myself. I would like to learn more about interpreting the data from FlashPro.

Once again, many thanks!

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: misfire at 3500rpm

Post by Spunkster » Fri May 31, 2019 12:03 pm

Is your ECU a PRA?

el colon
Posts: 22
Joined: Wed Jan 16, 2019 1:40 pm

Re: misfire at 3500rpm

Post by el colon » Fri May 31, 2019 1:44 pm

Spunkster wrote:
Fri May 31, 2019 12:03 pm
Is your ECU a PRA?
This is my ECU:

Image

Many thanks

User avatar
Spunkster
Site Admin
Posts: 17940
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: misfire at 3500rpm

Post by Spunkster » Fri May 31, 2019 2:05 pm

sorry, I mistook this for a K-Pro, ignore that question.

typer86
Posts: 310
Joined: Sun Oct 28, 2012 3:17 pm

Re: misfire at 3500rpm

Post by typer86 » Wed Jun 05, 2019 2:52 pm

I think I am be able to create a tune for you.
I have tuned some K20 SC via etune over the internet.

Post Reply