primary oxygen sensor failures

FlashPro Manager software
Post Reply
all-black
Posts: 82
Joined: Mon Jul 06, 2009 1:43 pm
Location: san ramon
Contact:

primary oxygen sensor failures

Post by all-black » Sat Mar 23, 2013 5:45 pm

was wondering if there is a way to look at the primary sensor voltage not the a/f ratio out of it. this would help for diagnosing o2 sensor failures... it seems very common for the 8th gen civic to have primary a/f ratio sensor failures. wondering if you guys have any other insight into why they fail so often in this platform. have another thought of if we could use an external wideband to have the ecu use for its close loop operation. i have yet to have a bosch wideband fail yet and its right next to the stock sensor, so you would think it would fail also from the running conditions if it were that...

ajpturbopittsburgh
Posts: 145
Joined: Wed May 26, 2010 10:58 am

Re: primary oxygen sensor failures

Post by ajpturbopittsburgh » Sat Mar 23, 2013 7:14 pm

I didn't realize that stock O2's failed often.

User avatar
Hondata
Site Admin
Posts: 8818
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: primary oxygen sensor failures

Post by Hondata » Sun Mar 24, 2013 8:04 am

Two main causes of failure: Vibration when hot (almost all after market headers cause this) and moisture (the mounting angle is important - again, the header design is responsible for this).
Hondata

all-black
Posts: 82
Joined: Mon Jul 06, 2009 1:43 pm
Location: san ramon
Contact:

Re: primary oxygen sensor failures

Post by all-black » Sun Mar 24, 2013 8:36 pm

is there a possibility to making the ecu run off a aftermarket wideband lc-1 or aem uego....i ask this because these sensors are not failing like the stock ones. is there any update coming alone for the si based rrb calibrations for taking care of the rev hang? i know it was talked about that it was going to be a feature added.

User avatar
Hondata
Site Admin
Posts: 8818
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: primary oxygen sensor failures

Post by Hondata » Sun Mar 24, 2013 9:18 pm

RRB calibration has the same rev hang fix as the race calibrations.
Hondata

all-black
Posts: 82
Joined: Mon Jul 06, 2009 1:43 pm
Location: san ramon
Contact:

Re: primary oxygen sensor failures

Post by all-black » Sat Mar 30, 2013 10:11 am

again is there any way to log the voltage of the stock sensor

User avatar
Hondata
Site Admin
Posts: 8818
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: primary oxygen sensor failures

Post by Hondata » Sat Mar 30, 2013 5:40 pm

The stock sensor works off current, not voltage. To calculate the sensor current the ECU measures the voltage drop across a known resistance, so while you can get voltage from the sensor, it is directly related to current and therefore lambda, so there is no real use to looking at the voltage.
Hondata

Post Reply