Page 1 of 1

New Computer, No USB Light

Posted: Sun May 27, 2018 10:04 pm
by AGordon3
Got a new computer recently, and needed to update my knock control tables. Fresh download of FPM, hooked up flashpro, went to update firmware and froze. Now I cannot get the red USB light to come on on the flashpro at all. Am I screwed?

FPM is version
FP Serial FP-SI-US-16001
Tried manually updating firmware, rapid plug/unplug. No dice.
I do get a green power light on the FP, but nothing else.
FP firmware is likely quite old, as it has been almost a year since my last adjustment.
I do get a green check on driver, but everything else has red X's on it (FP, OBD, ECU.)

It is a windows 10 desktop, and my car is not connected.


Re: New Computer, No USB Light

Posted: Mon May 28, 2018 6:44 am
by Hondata
See this: ... rmware.htm
Just unplug and replug the FlashPro until it shows up on the laptop, then update the boot firmware. Or you can use an older laptop to upload the boot firmware and then try your new laptop.

Re: New Computer, No USB Light

Posted: Mon May 28, 2018 7:08 pm
by AGordon3
Got it to work.

Oddly enough, if I unplugged and replugged repeatedly until it recognized the flashpro, then clicked 'OK' when it stated the firmware was to be upgraded, it would freeze FPM every time. I tried to 'X' out of the popup, and it updated just fine. Weird, but if it works it works.

I will check if the boot firmware needs updating now.

EDIT: Boot firmware updated. So far, so good. I was concerned for a moment that force closing FPM when it froze was going to brick my FP...Feeling much more relieved now. Thank you so much!

Re: New Computer, No USB Light

Posted: Mon May 28, 2018 7:54 pm
by Hondata
Once the boot firmware has updated then that is it. It should work ok with the new laptop now.