From VTEC to part throttle low cam, lean spike.

FlashPro questions & answers specific to the 2006-2009 (US, UK, Asia) S2000
Post Reply
liquid_helix136
Posts: 10
Joined: Tue Aug 27, 2013 11:59 am

From VTEC to part throttle low cam, lean spike.

Post by liquid_helix136 » Wed Feb 21, 2018 7:43 pm

Specs:
Custom 4" -> 3.5" -> 3" long tube intake, fuel surge tank running ~stock fuel pressure

I'm having a problem where if when I go from high cam tables back down to low cam tables, I will get a lean spike. So if I do any type of VTEC, part throttle or full throttle, then back off the throttle just a bit, back into low cam territory. The car will lean spike with a noticeable jerk before correcting.

I have attempted the same method, but below the vtec window, full throttle at 2700ish and back off around 3500 and I dont have the same problem.

You'll notice in the datalog, the s.trim is ranging below +/- 3% or so, with an L.trim of +/-1%, so the fueling appears to be well sorted.

If I fully let off the throttle prior to getting back on at part throttle, it will not lean spike.

Any insight would be appreciated greatly! Thanks.

EDIT: The best example of this on the datalog is from 1:40- 1:52 or so.
Attachments
leanspike1.fpdl
(5.92 KiB) Downloaded 43 times
Longtube-4.fpcal
(9.82 KiB) Downloaded 40 times

liquid_helix136
Posts: 10
Joined: Tue Aug 27, 2013 11:59 am

Re: From VTEC to part throttle low cam, lean spike.

Post by liquid_helix136 » Mon Apr 16, 2018 7:06 pm

nobody has an idea!?

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: From VTEC to part throttle low cam, lean spike.

Post by Spunkster » Tue Apr 17, 2018 10:33 am

It looks like you are decelerating and that is the cause.

liquid_helix136
Posts: 10
Joined: Tue Aug 27, 2013 11:59 am

Re: From VTEC to part throttle low cam, lean spike.

Post by liquid_helix136 » Tue May 01, 2018 5:48 pm

Lol what? Sure if i decelerate with my foot off the throttle it will go lean.

I'm talking acceleration from high cam tables to acceleration in low cam tables, I get a lean spike / jerk.

I can do the same motion, staying in vtec the whole time, or staying out of vtec the whole time, and the car operates normally. But if I go from hard acceleration to soft acceleration, crossing from high cam to low cam, it will lean spike.

I think this is different than just "decelerating."

User avatar
Hondata
Site Admin
Posts: 8728
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: From VTEC to part throttle low cam, lean spike.

Post by Hondata » Wed May 02, 2018 8:15 am

First I would suggest using the FlashPro to datalog, as your laptop is not sampling very quickly and it is hard to see what is happening.

Have you tuned the low load areas of each cam? For example, at 5000 rpm / 40 kPa one cam has 1450 fuel and the other 1000 fuel, so it could just be a lean spot there.

Also look at the point where the ECU switches to open loop and the fuel before that happens. At 0:52 you can see the ECU in closed loop but the fuel tuned rich, so the short term trim goes negative, and when you lift off the short term trim cause it to run lean.

I would also suggest putting the fuel table indexes back to stock as there is no advantage using columns every 1 kPa for tuning.
Hondata

Post Reply