A/F Steadily Goes Rich Until Stall at Idle

FlashPro questions & answers specific to the 2006-2009 (US, UK, Asia) S2000
Post Reply
imstimpy
Posts: 10
Joined: Mon Nov 04, 2013 2:04 pm

A/F Steadily Goes Rich Until Stall at Idle

Post by imstimpy » Fri Feb 23, 2018 5:44 pm

Car was at the track two weekends ago (as it has been many times) and just before a session it was idling, began to nearly die, catch, then idle to near death and repeat.

I reflashed the car and attempted to tune it out, but there are/were no anomalies in the tune. I was able to log the STRIM attempting to pull fuel though A/F continued to go super rich. The car seems to warmup fine and drive fine- idle not so much.

I have attached the log and am looking for ideas on where to go. Plugs were replaced prior to the track event and still look clean afterwards. I've checked compression and it looks good; no odd smells where they shouldn't be, either.
Attachments
URGE install I stalling.fpdl
(245.96 KiB) Downloaded 23 times

User avatar
Spunkster
Site Admin
Posts: 17206
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: A/F Steadily Goes Rich Until Stall at Idle

Post by Spunkster » Fri Feb 23, 2018 5:51 pm

IS the fan coming on when this happens?

imstimpy
Posts: 10
Joined: Mon Nov 04, 2013 2:04 pm

Re: A/F Steadily Goes Rich Until Stall at Idle

Post by imstimpy » Sun Feb 25, 2018 5:58 pm

No, it does not coincide with the fans.

After a long negative terminal pull, the car started and idled for 10+ min without issue. It wasn't until I shut it off and did a hot restart that the problem came back, manifesting as 19:1 AFR and misfires across all cylinders. This appears to electrical, rather than mechanical.

While I can't conclusively diagnose what, exactly, is the issue, I can say that something changes after the first restart. Since the ECU tracks things like idle re-learn, hot starts, start temperature, something is triggering it to go wonky. I am beginning to suspect the Flashpro, either a corrupted calibration or a problem with the live tables. I recently flashed back to a calibration I had from a year ago, also disabling live tables, and numerous hot starts did not exhibit the problem. I need to spend more time going through a full relearn, then iterating on various calibrations and live table states before I can confidently say what is going on.

imstimpy
Posts: 10
Joined: Mon Nov 04, 2013 2:04 pm

Re: A/F Steadily Goes Rich Until Stall at Idle

Post by imstimpy » Mon Mar 12, 2018 7:10 pm

Confirmed the problem does not exist in a year-old calibration with live tuning disabled. Also confirmed the problem does not exist in the same file but with live tuning disabled. Said another way, the problem existed on a file with live tuning enabled but the problem does not exist if the same file is resaved with live tuning disabled.

This is not the first time I've encountered unusual behavior by leaving live tuning enabled...

Attached are the live tuning and non-live tuning version of the same calibration.
Attachments
URGE install I good.fpcal
(9.68 KiB) Downloaded 22 times
URGE install I stalling.fpdl
(245.96 KiB) Downloaded 19 times

User avatar
Spunkster
Site Admin
Posts: 17206
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: A/F Steadily Goes Rich Until Stall at Idle

Post by Spunkster » Tue Mar 13, 2018 11:11 am

This is why you should only leave the live tuning on while you are actually tuning. It is not meant to be on at all times and be driven like that.

Post Reply