Can Adapter wiring 04-06 TSX

FlashPro questions & answers specific to the 2007-2008 US TSX
Post Reply
Gundam007
Posts: 2
Joined: Thu Aug 20, 2015 12:22 am

Can Adapter wiring 04-06 TSX

Post by Gundam007 »

Background: 04 TSX just installed 08 ECU (today) using the Can adapter (installed weeks ago) per the instructions that came with flashpro kit.
The Can adapter wires are properly installed, however the red wire will not properly remain within the 0BD2 harness. The directions say the wires only orient in one direction as far as fitment goes, and looking at the wire orientation that is correct, but when pushing the red one far into the harness it stays just like the white one, however it is pushed out everytime something is inserted into the 0BD2 port.
Eventually, I got it readable by only partially inserting flashpro harness connector to the OBD2 harness and preventing the red wire from budging to be able to upload the base map for the 04-05. But because the red wire will not stay in the harness the ECU cannot be consistently read. I had a separate ordeal caused by the partial insertion (I'm assuming) where flashpro calibration failed to upload and placed the ECU in recovery mode which as a first time user scared the crap out of me! I didn't move a muscle but this shouldn't happen. The white wire fits properly and doesn't budge, but what advice, tip, or tricks can be used to get the red wire to stay within the harness properly when connecting something to the OBD 2 port in the car? I know of a few others that are having or have had this issue.

User avatar
Spunkster
Site Admin
Posts: 18128
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Can Adapter wiring 04-06 TSX

Post by Spunkster »

If the pin will not stay in the connector then the clip that holds it has probably been damaged or broken in the connector. You may need to buy a new connector from the Acura dealer and de-pin your plug and replace the connector.

Gundam007
Posts: 2
Joined: Thu Aug 20, 2015 12:22 am

Re: Can Adapter wiring 04-06 TSX

Post by Gundam007 »

Is there not anything else it could be? I ask because I know of at least two others in the same boat. Is the harness that fragile that each of us broke it conceivably in the same way? I followed install directions to the tee.

Post Reply