suggest me a guideline please

FlashPro questions & answers specific to the 2010 CR-Z (US, Euro & Asia)
alollini
Posts: 58
Joined: Tue Dec 11, 2012 1:49 am

Re: suggest me a guideline please

Post by alollini » Thu Sep 05, 2013 4:15 am

Thank you for your help. IT WORKS!

The Kcontrol now looks stable between 40 and 55% while driving.

I had to bump up the knock sensitivity around 3000rpm AND from 5000 up. I did that with VERY small increment, so it took me time.

the behavior seem this :

-> when Kcontrol MOVES UP ( even if it stays below 100% )
--- then ignition timing freeze.
--- then some pattern appears in fuelling ( it basically bumps up to a way too rich 11.5/1 AFR )

-> The drop in power is obvious in the car when this happens.

Now problem is solved the power is good ==> all the time. ( with a steady 13.5/1 AFR at WOT )


EDIT : no the problem was not solved, sometimes it worked, sometimes not.
Last edited by alollini on Fri Mar 14, 2014 4:07 am, edited 1 time in total.
Team CR-Z Youtube Videos here => http://www.youtube.com/playlist?list=PL127E8C02C6B25D4B&feature=plcp
CR-Z GT White "Blue Inside"

alollini
Posts: 58
Joined: Tue Dec 11, 2012 1:49 am

Re: suggest me a guideline please

Post by alollini » Fri Mar 14, 2014 3:53 am

ok, trying to get rid of this Kcontrol 100% problem and this ultra-rich behavior at higher rpm;

i tried lowering ignition timing, up to a point where i felt i lost power. so i stopped. still no go.

then i started lowering knock sensitivity (putting higher values) but i was so much way off!

then I tried this plot 2D :
X axis RPM
Y axis K.level

assuming the engine was working ok, then i made a new knock sensitivity curve, identical in low and high vtec and identical from column 6 to 10 and the shape of the curve is an envelope 1% superior to the highest engine noise at each rpm, afer a 2 hour normal various driving datalog.

the new curve has nothing in common with the old one.

it works !

the engine is making less retard, does never richen, and feel punchier and more repeatable/consistent.

K.control stabilize at 21% then never moves.

the Rich ++ behavior was only happening when value of K.control moves up (even by 1%).


I have good torque at all rpm (no hole).
Team CR-Z Youtube Videos here => http://www.youtube.com/playlist?list=PL127E8C02C6B25D4B&feature=plcp
CR-Z GT White "Blue Inside"

Post Reply