CEL U0301 - ECM/PCM mismatch

FlashPro questions & answers specific to the 2010 CR-Z (US, Euro & Asia)
HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Sat Jun 02, 2018 9:51 am

Hi, I just joined this forum because I purchased a supercharged 2011 crz that is tuned with hondata. Nothing is mechanically wrong with it, but because of the state I live in (NY) any check engine lights prevent me from passing inspection. This crz has a U0301 code, which is "ECM/PCM incompatibility". Also on the dash information screen it reads "check transmission". I am not the only one to have this code and dashboard message. Two other crzs that I know of have gotten this (both them and myself all have CVT, not manual transmissions).

I visited my local Honda dealer today and they used their HDS unit to see what was going on. They said there was 1 transmission software update available for my car, but it wouldn't take it and they don't know why. They then diagnosed the issue, and it came up as PCM to TCM mismatch (which would explain the "check transmission" message).

I even swapped in a different ECU last week. As soon as I put the flashpro tune onto the new one, instant U0301 again. Tuning a CVT CRZ seems to be causing a software communication issue with the transmission. He gave me the program but it no longer works- it was a HDS program I downloaded to try but the public database wasnt available (thats gone now, Honda requires paid subscriptions for HDS units). But using a real HDS unit today at the dealer, I am not sure why it wouldn't let him download the TCM update that he said was available.

Is there anything Hondata can do to help CVT CRZs? Anyone else on this forum with a CVT have this issue? If I cannot solve this, return my car to stock... The supercharger is fun, I would like to avoid that. :)

User avatar
Hondata
Site Admin
Posts: 8581
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Sat Jun 02, 2018 10:04 am

The cause of the problem is that the ECU and MCM need to match. So either the ECU has the wrong software version or the MCM has the wrong version. We have seen causes where the dealer updates the MCM software to give this error or the MCM is swapped out (for whatever reason) to an earlier or later MCM with different software. Usually it is the dealer reflashing the MCM to later software but not reflashing the ECU as well.

What you need to do is to find the calibration ID for both the ECU and MCM . The ECU is easy, you can do that from FlashProManager but the MCM version requires the use of the Honda scan tool.
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Sat Jun 02, 2018 10:23 am

Wow thank you for the quick reply! I am contacting my guy at the dealer to see how soon he can scan my crz again.

May I ask what MCM is? I haven't heard of that module yet.

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Sat Jun 02, 2018 11:08 am

The ECU calibration ID is 37805-RTW-A550

I'll report back when I have the MCM and any other calibration IDs I can get from Honda.
Attachments
flashpro ecu calibration ID.jpg
flashpro ecu calibration ID.jpg (111.12 KiB) Viewed 1663 times

User avatar
Hondata
Site Admin
Posts: 8581
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Mon Jun 04, 2018 4:13 pm

Almost certainly the dealer reflashed the MCM from 2011 to 2012.

Can you go to the help menu and 'send support information'?

Also can you email your calibration to support@hondata.com? We need to change it so that it will load the 2012 binary for you.
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Tue Jun 05, 2018 6:55 pm

I gathered some calibration IDs today with the use of a dealership-owned HDS unit. Please see previous post for the ECU calibration ID. It appears that the ECM and PCM match, but the TCM does not (my car's info screen on the dashboard tells me "check transmission", also in the attachment for "CVT" ID notice that the HDS software is calling out the mismatch). You probably know what you're looking at, but to clarify to the best of my knowledge:

"CVT" is the TCM
"PGM-FI" is the PCM (MCM as you mentioned in an earlier post?)
"Electric Powertrain/IMA" is the hybrid motor
"EPS" is electric power steering (the master tech thought he better grab this too if its transmission-related)

After reviewing these calibration IDs, please let me know if you would still like me to send support information and email my calibration. I cant imagine how or why something would've been changed to 2012. This check engine light has existed since the car was first tuned by the first owner a couple years ago. I just acquired this car 6 months ago, so I guess anything is possible.

Thanks for your help, Hondata. I look forward to your next response...

Holly
Attachments
TCM.JPG
note the blue "mismatch" message
TCM.JPG (1.53 MiB) Viewed 1634 times

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Tue Jun 05, 2018 6:57 pm

I thought I attached all four photos, but perhaps there is a file size limit. I will post the other 3 separately.

PCM
Attachments
PCM.jpeg
PCM.jpeg (1.49 MiB) Viewed 1634 times

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Tue Jun 05, 2018 6:58 pm

The hybrid motor (IMA)
Attachments
IMA.JPG
IMA.JPG (1.59 MiB) Viewed 1634 times

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Tue Jun 05, 2018 6:59 pm

Electronic power steering
Attachments
Electronic power steering.JPG
Electronic power steering.JPG (1.49 MiB) Viewed 1634 times

User avatar
Hondata
Site Admin
Posts: 8581
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Wed Jun 06, 2018 9:49 am

Please send us your calibration and also the support information from the help menu.
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Wed Jun 06, 2018 7:08 pm

I have sent the support information, and just sent an email with title "HondaHolly - ECM/PCM Mismatch". Thank you!

User avatar
Hondata
Site Admin
Posts: 8581
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Thu Jun 07, 2018 9:51 am

Thanks. I believe we will have to make a release for this so it might take a week or two.
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Thu Jun 07, 2018 7:31 pm

Oh man, I am crossing my fingers! I'll keep an eye on this thread for any updates. Thank you! Hope this works out

User avatar
Hondata
Site Admin
Posts: 8581
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Thu Jun 21, 2018 1:49 pm

You are running a 2011 calibration. From 3.0.9.0 we've changed the software so that you can now use the 2012 calibration to match the transmission.

Can you try this out and let us know if the error is fixed?
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Fri Jun 22, 2018 2:39 am

Oh thank you! Can’t wait to try this out later today. So it’s as easy as updating to 3.0.9? Is there anything I need to select within the Flashpro software?

Post Reply