CEL U0301 - ECM/PCM mismatch

FlashPro questions & answers specific to the 2010 CR-Z (US, Euro & Asia)
User avatar
Spunkster
Site Admin
Posts: 17546
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Spunkster » Fri Jun 22, 2018 9:34 am

You must download the most recent software and start with a 2012 calibration.

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Fri Jun 22, 2018 2:09 pm

Ok, going to try this in a few hours. Hopefully I don’t have any trouble copying the tables onto the 2012 calibration.

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Fri Jun 22, 2018 6:35 pm

Still getting the same U0301 code and the same P062F; car dashboard info screen still telling me to "check transmission". Copied all tables and parameters from my old calibration file onto a brand new 2012 US CVT CRZ calibration file with the updated software. I did not drive the car around. Wouldn't think that would be necessary but I could try tomorrow.
What do we do now?
Attachments
6-22-18-errorafterupdate.jpg
DTCs
6-22-18-errorafterupdate.jpg (172.84 KiB) Viewed 1788 times

User avatar
Hondata
Site Admin
Posts: 8580
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Sat Jun 23, 2018 11:22 am

Can you use the 'send support information to hondata' function?
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Sat Jun 23, 2018 3:44 pm

Send Information completed. I also sent another email with the calibration file. Thank you so much for your assistance.

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Sat Jun 23, 2018 4:31 pm

Would it help if I were to grab all the calibration IDs again to see if anything changed? Before updating to 3.0.9 and creating a new 2012 file, these were my IDs and the TCM didnt match:
ECM: 37805-RTW-A550
PCM: 37805-RTW-A550
TCM: 37806-RTW-3050

User avatar
Hondata
Site Admin
Posts: 8580
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Sat Jun 23, 2018 6:17 pm

The A550 (2011) should be the right calibration for the ECU, not the 2012 A560.
But the 3050 in the TCM should be 2011 as well and work. I'll check again on Monday.
I suspect the bottom line is if you return to stock do you get the same code? If so, the dealer needs to flash the other modules to match.
Hondata

User avatar
Hondata
Site Admin
Posts: 8580
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Mon Jun 25, 2018 9:17 am

Another test is to use the 2011 calibration and then go to the Online -> Diagnostics window to look up the error codes. I'd like to see if the U0301 is generated from the PCM or TCM / MCM.
Hondata

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Mon Jun 25, 2018 1:06 pm

Ok so I’ll go back to my original calibration file?

HondaHolly
Posts: 16
Joined: Sat Jun 02, 2018 9:28 am

Re: CEL U0301 - ECM/PCM mismatch

Post by HondaHolly » Tue Jun 26, 2018 6:58 pm

Havent been able to go back to my original tune yet and looks at DTCs. Having some kind of issue with the Flashpro recognizing the VIN. I tried removing negative terminal for battery for 5 minutes, but maybe I should try longer. Will have my boyfriend (who does all my tuning stuff usually) look at it tomorrow.

Also, curiously, I cannot switch driving modes after changing my car to the 2012 calibration. May not be related, but it is odd. I am stuck in normal mode.
Attachments
VIN Error.jpg
VIN Error.jpg (134.57 KiB) Viewed 1723 times

User avatar
Hondata
Site Admin
Posts: 8580
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: CEL U0301 - ECM/PCM mismatch

Post by Hondata » Thu Jun 28, 2018 8:41 am

We'll be in touch via email.
Hondata

stjimmy
Posts: 15
Joined: Thu Dec 01, 2011 4:56 am

Re: CEL U0301 - ECM/PCM mismatch

Post by stjimmy » Sun Apr 21, 2019 9:11 am

I am having same issue on my J55 ecu with CRZ Asia CVT 2011 map. Using 2.8.3.0 version.

Should I try latest version? Or other way to fix this U0301 issue?

stjimmy
Posts: 15
Joined: Thu Dec 01, 2011 4:56 am

Re: CEL U0301 - ECM/PCM mismatch

Post by stjimmy » Sun Apr 21, 2019 8:46 pm

Upgraded firmware.. still showing CEL U0301. Same problem with HondaHolly.
Transmission Check lights on, Drive gear position blinking, but Mechanically working okay!
Please help.
Attachments
1.png
1.png (27.41 KiB) Viewed 990 times

Post Reply