Traction sync and datalog

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Traction sync and datalog

Post by gotslicks » Tue Nov 17, 2015 8:29 am

Finally got a chance to use my traction control and the first problem I run into is the traction control will not work and will not show up on the display screen in kpro unless both are plugged into my laptop via usb. Basically I have to have my laptop open and all on to make work.


Also the datalog function on the traction control will not show any data after you start and stop manually.

User avatar
Hondata
Site Admin
Posts: 8728
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Traction sync and datalog

Post by Hondata » Tue Nov 17, 2015 10:15 am

When you say 'traction control will not work' what do you mean? Do the wheel speed inputs work? Have you run through the test functions between the traction control output and ECU input?
Hondata

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Wed Nov 18, 2015 10:44 am

the actual traction control and its functions ie retard and wheel speed ect.....will only work when kpro and tc is plugged into a laptop with with the display on. i can physically see wheel speeds fr and r. it all works as it should.

i did all the test and nothing show up bad


when i just run the car nothing plugged into laptop nothing works. the lights blink on the module but there is no slip retard or speed of any wheel in my kpro data log......... if you open a laptop plug in kpro then plug in the tc module the usb then it all functions as normal.

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Traction sync and datalog

Post by Spunkster » Wed Nov 18, 2015 3:25 pm

Where exactly are you getting power and ground for the Traction control unit?

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Wed Nov 18, 2015 7:49 pm

At the pins you recommended in your install directions. Igp1 pg1.

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Traction sync and datalog

Post by Spunkster » Thu Nov 19, 2015 10:42 am

Does the power light come on when the key is on and USB disconnected?

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Thu Nov 19, 2015 12:34 pm

Yes. All lights come on. Iirc the usb light only comes on when plugged into the laptop

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Traction sync and datalog

Post by Spunkster » Thu Nov 19, 2015 12:48 pm

The only time you will get all data when datalogging is when you have both USB cables connected to both the K-Pro and the Traction control unit.

If you only have the K-Pro USB connected it will not be able to see the wheels speeds or other traction control related data. This does not mean that the traction control is not working.

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Thu Nov 19, 2015 4:59 pm

Ok. Like I said in the first post......the traction control will not work without a laptop I between it and the ecu. I went to a test and tune to find this out:(. I have also tested in the shop.....will not work without laptop connected.



The data log on the tc does not work either!!! But that's the least of my worries Atm but it does bring up a good question....... I assume that I will only see the voltage of the eld and watch the timing move?
After we figure this on issue out I Will need to get the data log working and I feel this issue is totally separate from the issue I am having now.

Back to the original issue......what should I do about the fact that the traction control will
Not work without the laptop. Where should I start to look? What steps do you want me to take for you to Help me Diagnose the issue?

I attached a data log to show you it is active only with laptop connected to usb in both.
Attachments
image.jpeg
image.jpeg (4.05 MiB) Viewed 4999 times

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Traction sync and datalog

Post by Spunkster » Fri Nov 20, 2015 11:08 am

The only reason that the traction control would not work without the laptop is if it is not getting proper power and is only being powered by USB. The USB does not communicate any data for it to work between the ECU and the K-Pro.

If you close and reopen the software then plug in the USB to the traction control unit, does it show the correct traction control data in the Traction control window?

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Fri Nov 20, 2015 12:26 pm

i dont quite understand your question?
are you saying close kpro. open kpro and plug usb in from tc unit to the laptop? should the usb to the kpro be plugged in or not?

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Traction sync and datalog

Post by Spunkster » Fri Nov 20, 2015 1:30 pm

K-Pro does not have to be plugged in, just traction control. Then see if the settings you have input show up in the traction control window.

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Fri Nov 20, 2015 4:48 pm

yes i does have my last settings and my registar name?

User avatar
Spunkster
Site Admin
Posts: 17864
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Traction sync and datalog

Post by Spunkster » Mon Nov 23, 2015 10:09 am

Post a datalog with the only the USB to the K-Pro plugged in showing it getting wheel spin.

Then post a datalog with both USBs plugged in doing the same thing.

gotslicks
Posts: 27
Joined: Wed Oct 16, 2013 8:15 am

Re: Traction sync and datalog

Post by gotslicks » Tue Nov 24, 2015 8:21 pm

so i did some more testing this weekend. i only changed some output parameters and i only used it plugged into the laptop and the kpro. After i came home i tested it on my lift and it will work without being plugged into the laptop. So that is one issue solved i guess. I changed nothing since the last time i was at the track?
The thing i do notice now, that i didnt notice before is after i turn the key on,the power light comes on and then 5 or so seconds later the orange usb light turns on. This is without the tc plugged into the laptop.


Now all i need to do is get the datalog to work in the traction control. it shows that it is logging but when you read it there is nothing there. any advice?

https://www.youtube.com/watch?v=odlw1k- ... e=youtu.be

https://www.youtube.com/watch?v=PkFB7ST ... e=youtu.be

Post Reply