Datalogging traction control with Kpro

Post Reply
Honda9ower
Posts: 26
Joined: Sun Jan 10, 2010 7:10 am

Datalogging traction control with Kpro

Post by Honda9ower » Thu Sep 27, 2012 1:24 pm

I'm having a bit of trouble datalogging. I have both USB cables in my laptop (Kpro and TC), but for some reason in Kmanager the TC Over, TC Retard and TC Limit sensor readings never change from zero?. I get mph readings for each wheel and TC Slip and TC Turn percentages, but the others stay zero. Also, TC Out is a percentage when I think it should be a voltage, and I can't change it to voltage in sensor setup.

I can see from the RPM trace that TC limit should be more than zero, and there is definately some ignition retard being applied as the IGN trace drops like a stone when the ELD voltage increases. Also, I don't have wheelspin where before I would have lit up the tires!.

I'm using the latest kmanager beta (3.1.6.0) and the latest traction control version (1.0.3.0). Is this a bug?

User avatar
Hondata
Site Admin
Posts: 8639
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Datalogging traction control with Kpro

Post by Hondata » Thu Sep 27, 2012 1:30 pm

Did you upload your calibration again to the KPro?
Hondata

Honda9ower
Posts: 26
Joined: Sun Jan 10, 2010 7:10 am

Re: Datalogging traction control with Kpro

Post by Honda9ower » Thu Sep 27, 2012 1:36 pm

Yes, kmanager gave me a message to do so!. I've also adjusted the traction control speed and rpm parameters to suit my car while tuning, so had to upload the new maps then.

User avatar
Hondata
Site Admin
Posts: 8639
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: Datalogging traction control with Kpro

Post by Hondata » Fri Sep 28, 2012 9:02 am

TC.Out is the amount of over slip, so is a percentage.

I've checked and it does datalog as expected.

How are you datalogging? Do you have the standalone traction control application open, or KManager, or both? Are you datalogging with the Traction Control window open in KManager?
Hondata

Honda9ower
Posts: 26
Joined: Sun Jan 10, 2010 7:10 am

Re: Datalogging traction control with Kpro

Post by Honda9ower » Fri Sep 28, 2012 10:12 am

I assumed something was wrong with TC Out as it always seems to show the same as the ELD voltage, rounded down to the nearest volt. I've never seen it go above 4%, even when TC Slip is as high as 40%.

When I datalog I will have done a variety of things, but most often I probably have both the stand alone application open (to read the help file) and also the Kmanager traction control window open as I will be tweaking the settings after each datalog. The stand alone application has 'inactive' at the top and all the options are greyed out.

Honda9ower
Posts: 26
Joined: Sun Jan 10, 2010 7:10 am

Re: Datalogging traction control with Kpro

Post by Honda9ower » Tue Oct 16, 2012 12:37 pm

Any thoughts on this? I've done some datalogging recently with just kmanager open and there's no difference. TC Over, TC Retard and TC Limit stay at zero no matter how much TC Slip there is.

I'm running Windows XP on a Dell Inspiron laptop if that's any help.

User avatar
Spunkster
Site Admin
Posts: 17671
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Datalogging traction control with Kpro

Post by Spunkster » Tue Oct 16, 2012 12:53 pm

Did you cut the wire that goes to the ELD?

Honda9ower
Posts: 26
Joined: Sun Jan 10, 2010 7:10 am

Re: Datalogging traction control with Kpro

Post by Honda9ower » Tue Oct 16, 2012 2:18 pm

Yes, wire cut and plumbed straight into the traction control.

User avatar
Spunkster
Site Admin
Posts: 17671
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Datalogging traction control with Kpro

Post by Spunkster » Tue Oct 16, 2012 3:11 pm

Can you post your calibration and datalogs here please.

Honda9ower
Posts: 26
Joined: Sun Jan 10, 2010 7:10 am

Re: Datalogging traction control with Kpro

Post by Honda9ower » Tue Oct 16, 2012 3:39 pm

I have attached my Kpro calibration, TC calibration and a datalog from the drag strip. TC was switched off for the burnout, then on with a target slip of 6 or 7%.

I had to rename the traction control calibration "Hondata traction control.kal" rather than .tcc as the forum wouldn't let me upload a .tcc file extension.

You can see that in first gear I get a high TC slip, but TC Over, TC Retard and TC Limit all stay zero. Looking at the IGN values, TC Retard was probably between 7 and 10 degrees, but this is not logged.
Attachments
Hondata traction control.kal
(1.01 KiB) Downloaded 282 times
hondata.kdl
(5.43 MiB) Downloaded 270 times
Hondata.kal
(151.09 KiB) Downloaded 286 times

User avatar
Spunkster
Site Admin
Posts: 17671
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Datalogging traction control with Kpro

Post by Spunkster » Wed Oct 17, 2012 1:56 pm

A new release of software will be available tomorrow which should correct the datalogging bug.

Post Reply