FlashPro's power LED doesn't turn on

Civic 2016+ 1.5 Turbo
Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

FlashPro's power LED doesn't turn on

Post by Evildoer » Fri Aug 10, 2018 6:52 am

One question, I just borough a new FlashPro and it's power light never came on. It will flash the ECU by itself or connected to a laptop but the light just won't come on. I know it has power since I can connect it to my phone using bluetooth while the unit is only connected to OBDII, and the mobile app runs. Is there anything I missed or is it a lemon unit?

Vehicle: 2018 Honda Civic Hatch Sport MT

User avatar
Spunkster
Site Admin
Posts: 16855
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro's power LED doesn't turn on

Post by Spunkster » Fri Aug 10, 2018 9:15 am

It may have been opened and the LED is just bent and not under the hole.

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Fri Aug 10, 2018 10:56 am

Now the datalog light flashing lightly when my FlashPro is connected to OBD and also when connected with laptop...Any idea what that is?

User avatar
Spunkster
Site Admin
Posts: 16855
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro's power LED doesn't turn on

Post by Spunkster » Fri Aug 10, 2018 11:25 am

This is normal

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Mon Aug 13, 2018 8:25 am

Question? Can I open it up and bend the LED back into the hole? Do I need a special tool to remove the LED?

User avatar
Spunkster
Site Admin
Posts: 16855
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro's power LED doesn't turn on

Post by Spunkster » Mon Aug 13, 2018 10:34 am

No special tools are needed.

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Mon Aug 13, 2018 3:07 pm

I can pull the LED out of it socket...Any suggestions?

Jun43
Posts: 252
Joined: Mon Aug 01, 2016 2:59 pm

Re: FlashPro's power LED doesn't turn on

Post by Jun43 » Mon Aug 13, 2018 3:19 pm

wait... why are you pulling it out.

just bent it back straight into the hole of the casing

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Mon Aug 13, 2018 4:46 pm

I can't see any legs of the LED, there is a cover at the base and only the LED stick out and everything else is covered.

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Mon Aug 13, 2018 4:47 pm

Sorry, I mean I can't pull it out and I cant see any pin

User avatar
Spunkster
Site Admin
Posts: 16855
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro's power LED doesn't turn on

Post by Spunkster » Mon Aug 13, 2018 4:54 pm

Have you removed the 4 screws and carefully removed the top?

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Tue Aug 14, 2018 6:39 am

Yes, can't see the pin of the LEDs, it's covered by a socket. File attached.
Attachments
20180814_093543.jpg
20180814_093543.jpg (906.95 KiB) Viewed 247 times

User avatar
Spunkster
Site Admin
Posts: 16855
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro's power LED doesn't turn on

Post by Spunkster » Tue Aug 14, 2018 9:57 am

Just make sure they are not bent and line up with the holes above them.

Evildoer
Posts: 10
Joined: Wed Aug 08, 2018 4:01 am

Re: FlashPro's power LED doesn't turn on

Post by Evildoer » Tue Aug 14, 2018 10:20 am

Can't see any pin...Can't even move them actually...So I can't do anything and it still won't turn on...

User avatar
Spunkster
Site Admin
Posts: 16855
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: FlashPro's power LED doesn't turn on

Post by Spunkster » Tue Aug 14, 2018 10:58 am

With the top removed can you see the light coming on?

Does it work normally other than the light if the light does not come on?

Post Reply