1800 RPM high idle, and will not go passed 4000 RPM

Post your non-Hondata questions / problems here.
Locked
Xtremebb20
Posts: 16
Joined: Thu Aug 20, 2015 4:52 pm

1800 RPM high idle, and will not go passed 4000 RPM

Post by Xtremebb20 » Sun Aug 23, 2015 12:40 pm

I grinded down to bare metal to get good grounds on the engine grounds and I got the car to start now I am getting a high idle fault 1800 RPM. I loaded a P30 b16a base map onto the S300. I verified all the following for the wiring. Also verified the IGN timing and its set on the RED on the crank pulley. and adjusted the throttle adjustment screw with IAC connector disconnected and set to 450 RPM. Engine will not go passed 4000 RPM and the check engine light will not flash codes after grounded the provide check engine light ground. VIA chassis adapter. The check engine light stays on.

A21 passed Continuity test
A23 passed Continuity test to ground
A24 passed Continuity test to ground
A25 passed voltage test
A26 passed Continuity test to ground
B1 has voltage <<<<<
B2 passed Continuity test to ground

B11 passed continuity test on B11
B12 showing continuity on B11
B13 passed Continuity test to distributer
B14 passed Continuity test to distributer
B15 showing continuity on B16
B16 passed Continuity test to ground

D11 passed Continuity test to TPS
D17 passed Continuity test to MAP
D21 Not Grounded This test was with the connector not connected and with the D connector disconnected from the ECU
D22 Not Grounded This test was with the connector not connected and with the D connector disconnected from the ECU

I don't know what else to check please help me.

Locked