"Datalogging not enabled" and connection issues

HondaLogger datalogging software questions and answers.
newgsrdriver
Posts: 7
Joined: Tue Feb 01, 2005 6:47 pm

"Datalogging not enabled" and connection issues

Post by newgsrdriver » Tue Feb 01, 2005 6:55 pm

Just got datalogging after having my s200 for a while (serial s200-0145). So I hook up my Dell, sure enough, no dice, wont connect. Just says "connecting" with nothing else. I play with the com ports, make sure everything is set properly and still, nothing. I check the website and see some Dells have issues. When I click connect, it tells me datalogging is not enabled. On the ECU screen, it still also says "not enabled."

So I say OK, try another laptop, this time a Sony. Plug it in, remove FIFO (or whatever) buffering, fire it up, this time it connects for a second then says "connection error." I play with the Com settings again. This time, I get it to sit at "connected" but the dash isnt showing anything. 248 temps, no needle movement. It says "connected" even though it still gives me the same "datalogging not enabled" error message when I click connect, and under ECU it still says datalogging not enabled, but it is connected.

This is all serial....is the serial to USB adaptor mandatory? Or is the connection there, just an issue with my activation code not working? Im assuming something is wrong if it keeps telling me datalogging is not enabled when in fact it should be. I doublechecked my code with the dealer, and it wasn't written down wrong. Im not sure whats wrong here. Thanks!

DaX
Posts: 487
Joined: Tue Mar 18, 2003 3:48 pm

Post by DaX » Tue Feb 01, 2005 8:17 pm

With Dells you are required to use the USB to serial adapter if I am not mistaken. Be sure to use the keyspan one. I also just purchased the datalogging option and have had zero beef with the datalogging after using the Keyspan.

I installed the keyspan software and then opened the properties menu for the software and clicked on the Port Mapping tab to find out what COM port it uses [mine uses COM5]. I then went into Hondalogger and under File/Settings/Recording set the serial port to COM5. My timeout is 100ms and my max errors per second is 5.

It sounds like you don't have the datalogging enabled on the ECU. Get the unlock code from Hondata. Turn on your laptop and hook up the keyspan adapter. Open Hondalogger. Turn your key to the ON position. Click Connect to ECU. Hit CTRL+M and enter the unlock code.

This should do the trick!

EDIT - I found this link helpful: http://www.hondata.com/connectivity_issues.html

newgsrdriver
Posts: 7
Joined: Tue Feb 01, 2005 6:47 pm

Post by newgsrdriver » Tue Feb 01, 2005 9:11 pm

Thanks man!

I followed all of the suggestions Hondata had on the site prior to posting. Since I ended up technically "connecting" with the Sony laptop, Im wondering if there is an unlock issue. It still says datalogging not enabled. I got the code from an auth dealer, I entered it, it just never says "enabled."

newgsrdriver
Posts: 7
Joined: Tue Feb 01, 2005 6:47 pm

Post by newgsrdriver » Wed Feb 02, 2005 6:53 pm

Spoke to Javier today, going to try and switch the ECU to OBD1 v2.5 from 3.0 to see if it works. He suggested 3.0 but its already set to 3.0, Ill try 2.5 and go from there.

newgsrdriver
Posts: 7
Joined: Tue Feb 01, 2005 6:47 pm

Post by newgsrdriver » Thu Feb 03, 2005 4:00 pm

Didnt work...

Cant think of anything else other than to send it to Javier to get it examined/fixed. I posted on HT as well to see if anyone has had this problem. Im thinking something isnt right with the software or the box, because it IS saying connected.

DaX
Posts: 487
Joined: Tue Mar 18, 2003 3:48 pm

Post by DaX » Thu Feb 03, 2005 5:07 pm

That is weird...and I am at a loss. Please post up what you resolve.

Pats Toy
Posts: 4
Joined: Mon Jan 24, 2005 3:20 pm
Location: Ottawa, Ontario, Canada
Contact:

Post by Pats Toy » Sat Feb 05, 2005 1:55 pm

Have you tried setting the ECU type/version setting to auto detect. I have had V3 connect problems and setting to auto detect almost always lets me connect and record.

Hope this helps :wink:

newgsrdriver
Posts: 7
Joined: Tue Feb 01, 2005 6:47 pm

Post by newgsrdriver » Sun Feb 06, 2005 9:01 pm

No I havent, I didnt see an auto detect, I will check for that though.

Does anyone know where I can download an older version of Hondalogger as well to try? Maybe its a bug in the software...Im thinking its either the software or the box that wont accept my code for some reason, so Id like to try an older version.

Pats Toy
Posts: 4
Joined: Mon Jan 24, 2005 3:20 pm
Location: Ottawa, Ontario, Canada
Contact:

Post by Pats Toy » Mon Feb 07, 2005 11:20 am

You might not have it if your'e using a newer version of Hondalogger. If you can get a copy of the original V3 it's worth a try.

Good Luck!

Clutch
Posts: 54
Joined: Wed Nov 17, 2004 6:03 pm
Location: Tennessee

Re: "Datalogging not enabled" and connection issue

Post by Clutch » Tue Feb 08, 2005 10:52 am

newgsrdriver wrote:Plug it in, remove FIFO (or whatever) buffering,
With the new "s" seriers hondata, It is recomended to not remove the FIFO buffering. Leave it checked. Try that and see if it helps!

HCats
Posts: 7
Joined: Fri Dec 31, 2004 5:42 pm
Location: Jakarta
Contact:

Post by HCats » Tue Feb 08, 2005 2:16 pm

we have the same problem, I have also followed the connection issues and the romulator instruction as well but still could not load Rom to Emulator.

I have my laptop (Toshiba Satellite) partitioned and install the system on E: I am thinking that this maight makes the connection/kayspan USB dont work properly since this my USB R232 not digitally signed. Now I re install it on C: and hope this will work.

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Post by Spunkster » Tue Feb 08, 2005 2:33 pm

HCats wrote:we have the same problem, I have also followed the connection issues and the romulator instruction as well but still could not load Rom to Emulator.

I have my laptop (Toshiba Satellite) partitioned and install the system on E: I am thinking that this maight makes the connection/kayspan USB dont work properly since this my USB R232 not digitally signed. Now I re install it on C: and hope this will work.
Have you tried using the utilities that installed witht eh Keyspan adapter? Try running the Keyspan Serial Assistant...if it says idle, then somehting is not right still, if it says busy, it is properly connected nad the drivers are loaded.

newgsrdriver
Posts: 7
Joined: Tue Feb 01, 2005 6:47 pm

Post by newgsrdriver » Sun Feb 13, 2005 10:25 am

I cant seem to locate an older Hondalogger version. I ordered the keyspan adapter. Ill try that, and if it doesnt work I guess Ill send it out.

HCats
Posts: 7
Joined: Fri Dec 31, 2004 5:42 pm
Location: Jakarta
Contact:

Post by HCats » Tue Feb 15, 2005 6:24 am

Spunkster, but can you tell me more detail about how to run the Keyspan Serial Assistant? I am using RS232 product of SemiTech Semiconductor.

Thanks for helping.

User avatar
Spunkster
Site Admin
Posts: 18073
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Post by Spunkster » Wed Feb 16, 2005 11:24 am

You have to be using a Keyspan adapter to have and use the Keyspan serial assistant.

Locked