2012 TSX Fuel maps having no effect

FlashPro questions & answers specific to the 2007-2008 US TSX
Post Reply
VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

2012 TSX Fuel maps having no effect

Post by VitViper » Sun Feb 15, 2015 6:47 pm

Until after 6800 rpm. I can keep increasing fuel on the high cam SD fuel tables on this vehicle and they have zero effect on IDC and the actual fueling -- until after 6800 rpm, then it will go pig rich. I'm sending you two logs & cals for reference, in the 2nd one I added 10% fuel to all of the high cam, and you can see the result.

User avatar
Hondata
Site Admin
Posts: 8774
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: 2012 TSX Fuel maps having no effect

Post by Hondata » Tue Feb 17, 2015 12:01 pm

The injector duration doesn't seem to follow the fuel table above 7000 rpm.
The throttle pedal is not at 100% for one of the runs. This may be a factor.
The cold temperatures (15F) have pushed the duty to over 90%, at which point the injectors tend to float open, effectively being 100% duty. This obviously doesn't affect the injector duration but is probably the cause of the AF going very rich. Even then, there is a lot of fuel for a NA vehicle to get the duty this high.
If you can re-test what we do here is fix the cam angle and make a single fuel table row much higher. This will verify the correct table is being used and the indexing is correct.
Hondata

VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

Re: 2012 TSX Fuel maps having no effect

Post by VitViper » Tue Feb 17, 2015 3:54 pm

Please look at the logs and the maps I sent you again.

I added 10% fuel *everywhere* in vtec, including before 7000 rpm, and the only region the fuel map has any response is after 7000 rpm (hence the going rich). The throttle pedal not being 100% -- who cares? TPLATE is 98* in one log and 101* in the other -- irrelevant, both WOT.

Look at 6033 rpm in both logs. MAP is the same, DUty cycle is the same, INJ pulsewidth is the same, however the fuel map in the 3.3 revision is 10% higher.

You're telling me this isn't a problem? I'll pass that on to the customer as "working as intended".

VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

Re: 2012 TSX Fuel maps having no effect

Post by VitViper » Tue Feb 17, 2015 4:02 pm

Here's a visual. So a 10% change on the whole fuel map, at every single cam angle break point, only having an effect after 7k rpm is working as intended? WE get a 4% duty cycle and a .7ms IPW change at 7k and a 0% duty cycle with a .01ms IPW change at 6033 with a 10% fuel change?
workingasintended.png
workingasintended.png (50.83 KiB) Viewed 5090 times

User avatar
Hondata
Site Admin
Posts: 8774
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: 2012 TSX Fuel maps having no effect

Post by Hondata » Tue Feb 17, 2015 7:04 pm

I'm not telling you there is no problem - just suggested some things to try and narrow the problem down.
Hondata

VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

Re: 2012 TSX Fuel maps having no effect

Post by VitViper » Wed Feb 18, 2015 2:29 pm

Hondata wrote:I'm not telling you there is no problem - just suggested some things to try and narrow the problem down.
OK...

The vehicle was tuned by locking the individual break points, that's the only way to properly tune the car to begin with. I've gone back and went through a few more tests with the customer's car:

- Locked 40 cam, fuel changes on the fuel map have no impact.
- Locked 0 cam, fuel changes work as intended.

I'm verifying 15 & 30 to see where the split happens...

Zoro2006
Posts: 119
Joined: Sun May 02, 2010 3:07 am

Re: 2012 TSX Fuel maps having no effect

Post by Zoro2006 » Thu Feb 19, 2015 7:41 am

not the first time such things happen to Acura TSX CL9 owners, basicaly same issues when adding more fuel and it didn't reflected in logs I saw with older FlashPro Manager ver. 1.5.6
Known as Vaikis_

VitViper
Posts: 273
Joined: Thu Aug 27, 2009 10:38 pm

Re: 2012 TSX Fuel maps having no effect

Post by VitViper » Tue Mar 03, 2015 12:59 pm

The same thing is happening on a customer's 2014 TSX. Hit 15 cam and fuel mapping no longer responds. That's 2 TSX's I cannot finish tuning due to the issue.

User avatar
Hondata
Site Admin
Posts: 8774
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: 2012 TSX Fuel maps having no effect

Post by Hondata » Thu Mar 05, 2015 8:21 am

We're looking at this. I'll keep you posted.
Hondata

User avatar
Hondata
Site Admin
Posts: 8774
Joined: Thu Aug 15, 2002 12:13 pm
Location: Torrance, CA
Contact:

Re: 2012 TSX Fuel maps having no effect

Post by Hondata » Tue Mar 10, 2015 8:46 am

Fixed for release 2.0.9.

Note that only the 2011+ TSX was affected.
Hondata

Post Reply