Stock primary O2 vs Analog Wideband Input

FlashPro Manager software
Post Reply
balla_EG6
Posts: 15
Joined: Sun Jul 20, 2014 9:02 pm

Stock primary O2 vs Analog Wideband Input

Post by balla_EG6 » Tue Feb 06, 2018 4:03 pm

Hello guys

I have an AEM UEGO attached to B29 (EGR) and configured in closed loop as the wideband input.

At logs, I see that past 4000rpm , the stock O2 (corrected) differs from the UEGO a bit. Eg, 0.87 lambda at stock and 0.83 at AEM. No matter what, Hondata uses the Stock O2 for closed loop (even setting the EGR pin as wideband input), so I cant fix my A/F ratio. My WOT target is 0.86.

Thats a bad stock O2 maybe ?

Any fixes besides changing to a new stock wideband sensor?

Thanks
2004 EVO VIII - www.nrteam.org

balla_EG6
Posts: 15
Joined: Sun Jul 20, 2014 9:02 pm

Re: Stock primary O2 vs Analog Wideband Input

Post by balla_EG6 » Tue Feb 06, 2018 4:11 pm

just tought about cheating my WOT target to 0.90 to see if my AEM reads 0.86 ...
2004 EVO VIII - www.nrteam.org

User avatar
Spunkster
Site Admin
Posts: 18083
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stock primary O2 vs Analog Wideband Input

Post by Spunkster » Tue Feb 06, 2018 4:49 pm

What vehicle are you referring to?

balla_EG6
Posts: 15
Joined: Sun Jul 20, 2014 9:02 pm

Re: Stock primary O2 vs Analog Wideband Input

Post by balla_EG6 » Wed Feb 07, 2018 4:59 am

Sorry... Civic SI 2008 with K24Z block. Invidia header, Injen CAI, ID1000 injectors, 12.5:1 pistons, ethanol. FlashPRO bt
2004 EVO VIII - www.nrteam.org

User avatar
Spunkster
Site Admin
Posts: 18083
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stock primary O2 vs Analog Wideband Input

Post by Spunkster » Wed Feb 07, 2018 1:47 pm

How exactly do you have the AEM wideband wired (power, ground, signal)?

balla_EG6
Posts: 15
Joined: Sun Jul 20, 2014 9:02 pm

Re: Stock primary O2 vs Analog Wideband Input

Post by balla_EG6 » Wed Feb 07, 2018 2:41 pm

Power - ign 12v fusebox
Ground - under fusebox (chassis)
Signal - UEGO white wire to ECU B29 EGRL

Voltage offset 0v
2004 EVO VIII - www.nrteam.org

balla_EG6
Posts: 15
Joined: Sun Jul 20, 2014 9:02 pm

Re: Stock primary O2 vs Analog Wideband Input

Post by balla_EG6 » Wed Feb 07, 2018 2:48 pm

At low rpm they seem to show very similar AFRs

The uego sensor is 2" from stock
2004 EVO VIII - www.nrteam.org

User avatar
Spunkster
Site Admin
Posts: 18083
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stock primary O2 vs Analog Wideband Input

Post by Spunkster » Wed Feb 07, 2018 5:20 pm

Unfortunately I do not have any way for you to make an adjustment to make them match in this instance.

balla_EG6
Posts: 15
Joined: Sun Jul 20, 2014 9:02 pm

Re: Stock primary O2 vs Analog Wideband Input

Post by balla_EG6 » Wed Feb 07, 2018 7:26 pm

I will try a new O2 sensor.
Must be OEM HONDA ?
2004 EVO VIII - www.nrteam.org

User avatar
Spunkster
Site Admin
Posts: 18083
Joined: Fri Sep 20, 2002 5:06 pm
Location: Hondata
Contact:

Re: Stock primary O2 vs Analog Wideband Input

Post by Spunkster » Thu Feb 08, 2018 10:09 am

About the only thing I can think for you to try would be to ground the Wideband to one of the ground wires at the ECU.

Post Reply