Need help tuning

2012+ US/Canadian Civic Si / 2013+ ILX
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Interesting how it happens all the sudden like that. Have you tried the idle relearn process? I'm not sure it would help, but it might be worth a shot before getting a new TB.
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

I have but maybe I’m doing it wrong. Do you know the process to follow. I’d be willing to throw it another shot and tbh this is a new throttle body already. Could it be a wiring issue?
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Most guys just pull the negative battery cable for 15-20 minutes. I believe there is a more in depth process that can be done, especially with dealer equipment. If you had the problem prior to the throttle body, then yes it could be wiring issue. Hard to say though without someone looking at it.
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

Okay so I tried that, and it still happens. I’m gonna see if I can find the full reset online and also try using a multi meter on the harness and everything. Might be something stupid.
But also another question, is there a way to tune to make the rev hang go away and also make the throttle a little more sharp?
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Okay, see what you can find out. Since you had the issue before after replacing it makes me think something else is going on.

The rev hang is already turned off, and the pedal map is much more direct than OEM. But I believe I have a sport pedal map somewhere we can try. But would work on the issue at hand first before worrying about all that. If the TB is having an issue of some sort, that could be fighting itself.
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

okay , so im checking all sensors to see what could be the key because it happens after idling for a while so i dont think its just throttle body issues. i havent had a full chance to have a look since its been constanly raining here. i appreciate it too. ill keep everything updated when i get the chance
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Sounds good, keep me (us) in the loop.
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

so after some time diaging the car and everything i got info on either the pcm is bad or i got a bad throttle body. so question is if i get a new pcm do i need to go to the dealer or can i use hondata? im considering ordering both and just eliminating all possible outcomes, thank you in advance and i know its been some time.
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

The new ECU will need to be coded for your car. The one main thing you will need to do is unlock your FlashPro from your current ECU before you do the swap. If the FlashPro is locked on your current ECU, you will not be able to lock it to the new ECU. So before you physically pull your current ECU, make sure to unlock the FlashPro first. That will save you money and a headache down the road.
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

so big update, my buddy gave me the idea that the intake should be heat wrapped because its aluminum piping all the way through/ it got super hot and could cause really high iats and could cause the issue. so i did that and it seems to be working. let car idle for an hour no issues so far gonna double check tomorrow and send over some data logs. seems a little different in the throttle after doing an idle relearn. thanks again. i do appreciate all the advice so far and help.
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Sounds good. We'll see how it looks. And your friend is right about the heat, the heat is our enemy.
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

so heres the logs i got. car drives good just throttle seems "laggish" so i threw in a little wot. also have a clean idle log. thank you for your time.
Attachments
idle log 2.fpdl
(96.55 KiB) Downloaded 4 times
city drive with 2nd 3rd wot.fpdl
(127.8 KiB) Downloaded 4 times
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Yeah the idle looks a lot better for sure. Overall it's not too bad, but we need to shoot for 20 minutes or so on the datalogs so we can get some good average data. The WOT fuel was definitely on the rich side, so I made a big adjustment there. Try to get a clean third gear pull from 2500-7500 if you can. That gives us the best data pool to make WOT fuel adjustments. But things definitely look better, we'll see if it feels stronger in this next one.
chrisconig0.SD.Rev02 (Blended)(Vtec4500).fpcal
(22.7 KiB) Downloaded 3 times
chrisconig0
Posts: 19
Joined: Thu May 05, 2022 5:35 pm

Re: Need help tuning

Post by chrisconig0 »

so i made the datalogs i did pulls for you. i tried to keep different driving patterns to see if that help. definitely drove a lot cleaner. feels way more responsive. seems to drive a lot cooler now too with the wrap. glad it fixed the issue even though it was something stupid. thank you again
Attachments
city and wot driving revison 2.fpdl
(685.47 KiB) Downloaded 4 times
EFICU
Posts: 3299
Joined: Mon Feb 25, 2019 10:14 pm

Re: Need help tuning

Post by EFICU »

Looks really good. I made some small tweaks now with the WOT data. For this next one, really try to make a pull in third gear from 2500-7500 if you can. That long sweep is what we need to fine tune the fuel for WOT. It's about 90% there, so we're looking good. That type of pull will give me the data to fine tune it.
chrisconig0.SD.Rev03 (Blended)(Vtec4500).fpcal
(22.78 KiB) Downloaded 4 times
Post Reply